[Webmin] Blank page (BUG)

SYSTEM INFORMATION
OS type and version Ubuntu focal x64 v 20.04
Webmin version 2.021

I use my dedicated linux server without interruption, so i think there is a problem with cache, because i got a continuously loading bar of page after some weeks, without any result from loading(dashboard), but if i restart webmin will work again.

This could be dependent on the user you log in as. You have to grant permissions to users in webmin.

What? even for root? the image shows OP signed in as root

is pretty meaningless for those finding this topic in the future

I guess I paid too much attention to ‘first time poster’ status.

OP. I have an occasional browser problem. Normally I can fix it by hitting the stop loading icon and then reloading. Doesn’t happen often though. If restarting webmin fixes it you might want to look at system resources.

I use multiple browsers regularly. Have you tried another browser?

1 Like

You’ll need to look in the Webmin error log to see what’s wrong (/var/webmin/miniserv.error. We can’t possibly guess.

If there are no log entries that would explain it, check for OOM killer errors in the kernel log (dmesg, but it may also log to other locations, liker a file in /var/log or the journal).

guess what, i can’t guess too the errors from that log, so i will let devs or who know to read, the latest errors(which doesn’t are related to my bug…)

with service reload didn’t worked, but worked with service stop and start

to be honestly, this is not the first time when i encounter this bug…wasn’t present in previous version

sys info - https://i.imgur.com/wtoiL7C.png

“BIND8” aren’t we on BIND9 ? So system not updated ?

Thanks. The easiest way to copy SYSTEM Info for the forum is to use the "Copy basic info " button top right on the dashboard.
Further down the dashboard in the panel “Software versions” it should show which BIND version you have. It should be 9.18 for webmin 2.021

No. The bind8 module supports bind9. They have the same config file format. It’s an accident of history. For many years it was common to see both bind4 deployments and bind8 deployments, sometimes even in the same organization…and they have incompatible config files. BIND 9 uses the same config file format.

Unless the problem occurs only on some BIND pages (your screenshot does not appear to be on any BIND page) then the errors in that log are not relevant to this problem.

The “too many connections from network 104.152.52.0” may be relevant, if that’s your network. (Though I don’t think it is relevant. I would guess that’s some rando trying to do something nasty.)

Check the kernel log for OOM killer messages as I suggested above.

And, if none, check the Web Developer console in your browser for JavaScript errors (that seems unlikely, but I’m running out of guesses).

I’ve had this happen to me twice and both times I was able to resolve it by changing my DNS server ip in network settings from whatever the DATA Center had it configured to from their installation script to google DNS servers.

On the last one I even disabled ipv6 in Webmin Config because the server isn’t setup to use ipv6.

That actually would be a bug! Webmin should never need DNS resolution to work in order to show the UI! (But, I can’t think of how that could be.)

Edit: But, also lots of other things will break if you have IPv6 configured but in a non-functional state.

Joe, in logs it shows that in his Regex is an A escaped \A

Maybe for regex \ is escaped \ and A shouldn’t be escaped, and that confuses Webmin?

Just asking.

With new version of webmin i didn’t encountered the same problem, but today i had 500 webpage error while webmin was running normal. After webmin restart the problem disappeared.

Here are sys info from webmin clipboard

|  SYSTEM INFORMATION||
|----------------------|---------------------------|
|  OS type and version |     Ubuntu Linux 20.04.5     |
|  Webmin version      |     2.102      |
|  Theme version       |     21.05      |
|  Package updates     |     All installed packages are up to date   |

Here is a screen from miniserv.error, spamming something till i restarted the webmin.

Before restart:

After restart:

What page did the problem happen on?

The whole webmin page(site:10000 , dashboard/all) stopped to respond, with blank black web page error 500(not internal), the web page wasn’t accessible anymore, i think app was crashed due that spamming thing from webmin error log