Webmin 1.941 and Usermin 1.791 released

Howdy all,

I’ve rolled out version 1.941 of Webmin and 1.791 of Usermin to all repos.

This is a minor release which updates the theme and fixes a few minor bugs, but also re-introduces the ACME Tiny Let’s Encrypt client as a fallback for hosts that don’t have certbot available. It uses a newer version than previous Webmin releases, to support the new Let’s Encrypt 2.0 protocol (deprecation of the old protocol was why the previous ACME Tiny was removed in Webmin 1.940…it didn’t work anymore).

Note that the full version of certbot is still needed for wildcard certificates, so if you need wildcards you’ll need to be on a relatively recent distribution that has the full certbot package available (certbot-auto for older distributions does not support wildcards).

As always, let us know about problems.



Hi Webmin team! This works on CentOS 6. Sweet! I am not using wildcards so can’t confirm yes or no to that working.

I do have one very early install of CentOS 6 which was done using the old install method. I have to update Webmin via Webmin configuration. At the moment the new version doesn’t seem to ba available from webmin.com?

Already I’m getting success instead of fail on what was becoming hoards of notices. Now if I can get this one last server updated, I’ll not longer be spamming myself. :slight_smile:

Thanks for the work on this issue. It’s rotten when something comes down from someone else which forces new problems. Me? I am hoping Virtualmin will be available for CentOS 8 before CentOS 6 goes EOL so I can move everyone at that time.

Wildcards will not work without native certbot client, which isn’t available on CentOS 6.

I am hoping Virtualmin will be available for CentOS 8 before CentOS 6 goes EOL

We will do absolutely our best. Joe is working on it. There are few hard to solve issues left to deal with.


I run into an issue after updating to the latest Webmin.

On a Debian 9 server, when trying to renew Let’s Encrypt on a Virtual Server with many domains and sub-domains as aliases, this happens:

.. request failed : Web-based validation failed :
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA. You may need to use an authenticator plugin that can do challenges over DNS.
Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA. You may need to use an authenticator plugin that can do challenges over DNS. 

The DNS-based validation also fails since it is not applicable in this case.
Certbot is installed … but it does not seem to be used. Am I right? Can I somehow force the use of Certbot?

Is there any ETA on when this update will be available via webmin.com?

I have one system that has to update via the Webmin Configuration -> Upgrade Webmin. When I click Upgrade Webmin, I get a message saying I’m already running the latest version but that system is on 1.940.

It probably won’t. Jamie doesn’t usually make Webmin devel releases available via the Webmin.com repo. You could switch to the software.virtualmin.com repos (e.g. http://software.virtualmin.com/vm/6/gpl/universal/ for CentOS/RHEL/Fedoea) even if you aren’t using Virtualmin on this system. Or you could download the RPM from the development releases link on Webmin.com.

This release was made specifically for Virtualmin users, and not to address any security issues or whatever, so it’s unlikely to get special treatment on Webmin.com.

Hi Joe,

I tried that and was successful in doing a repair on one of my old C6 systems, but on this system it failed and I had to do an undo to get back to where I was. This install was done using the old method for Webmin/Virtualmin installs. When I talked to Jamie about it he said enabling that repository most likely wouldn’t work. I do need to say I tried this perhaps a couple of years ago. Unfortunately, this system is pretty well loaded with domains and users and is planned to be moved to CentOS 8 when I can. And I can’t wait to be able to do that.

Did you install it from a tarball!? In this century!? :wink:

I don’t know what you mean by “old method”, as the Virtualmin install.sh has always used packages and it’s existed since 2007 and has been the recommended installation method since then; it got a major re-factor maybe three years ago, but it always used RPM/deb packages and proper yum/apt repositories and it’s always safe to use those repos for new or old installs (done with install.sh). But, if you’re using a tarball+wbm installation, then, yes, you’re stuck with it and can’t really safely switch to RPM or deb-based installation type. We have a tar/wbm repo on https://software.virtualmin.com/gpl/wbm but I don’t think anybody uses it (I hope nobody uses it!), so I have no idea whether it’s good to use. I haven’t tested it in at least a decade (when we stopped supporting Solaris in the Virtualmin installer).

For future reference, never ever install anything from tarballs!

It was done maybe before virtualmin.sh existed I believe. It was an install of Webmin and then from within Webmin I could install Virtualmin. All updates had to be done through the Webmin module using Upgrade Webmin.

LOL… yeah, it was done in this century although not this decade, but it might have been 2012. To the best of my recollection it was done using webmin-1.590-1.rpm. The hardware was upgraded some time back but the OS was copied over. 6 is still not EOL. :slight_smile:

It definitely wasn’t before install.sh (CentOS 3 was the first CentOS version supported, long before 6 existed), but installing manually has always been possible, just not recommended.

But, as long as it’s an RPM, there’s nothing to worry about, it is the same package. You just don’t want to try to switch between install types (i.e. don’t go from a tarball to an RPM or vice-versa). You also would not want to switch a wbm module installation to an RPM (so, if you installed the virtual-server module from the Webmin Modules module, you’d have to keep that install type). Just install the 1.941 RPM from the devel section of the Webmin website. All package types are there, including a tarball. So figure out what you have, and just download the new one and install it with the appropriate tool.

WooHooooo! I’m now 100% up and running on all systems. Thanks Joe. I had never explored the dev area on the site. I tend to shy away from development versions. I guess at some point these become the final release versions.

Thanks so much for your quick replies. I really appreciate cloudmin/virtualmin/webmin/usermin and the entire team.

Hello, was install.sh got updated too with 1.940+ release?

I’m using playbook for custom installs based on it, just checking if there are drastic updates.

Thank you.

I think there is an issue with the file manager file edit function after this release. I first notice it on a vps that I upgraded. I went to edit a file and it states that the file was saved but it does not save the file. I was logged in as root user. It threw me for a loop until I realised it was not saving the file. I shelled in and used vi editor and it saved OK. Last night I upgraded a dedicated server (both servers are CentOS 7). After the update I noticed that I could not edit a file using file manager; it states that it is saving the file but it isn’t. Now I know it was the update because the day before I updated, I had used the file manager to edit the same file and it saved my edit. After the update; still logged in as root, it would not save my edits.

Is this forum moderated? I posted a possible bug report on a new release and there isn’t any acknowledgment.

The forum is moderated, but your comment showed up, but I guess nobody who needed to see it saw it. Bugs are best reported in the issue tracker (either the relevant github issue tracker or the one on Virtualmin.com). I’m pretty sure this one has been reported elsewhere, and the problem is fixed in the next release. @Ilia would know for sure.

I really missed this quote. @Joe Thank you for mentioning me.

It’s been fixed a while ago. Make sure that you’re running latest Webmin 1.941 with the theme 19.45. Try force reloading the page, if issue persists.

This is interesting because another rival control panel experiencing this exact same issue as we speak…file manager not saving. Fancy that!

I will restart webmin and then if I see the same issue will report it in the proper place. Thank you and the team for all the work you put into webmin/virtualmin.

What? Are you saying that someone possibly using our File Manager libs? I doubt it’s possible though. Okay, which panel are you talking about exactly?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.