Warning! Incorrect MySQL password

Hi, I am new to Webmin/Virtualmin. Last 10+ years i was using shared web hosting…

I was following tutorial about how to install virtualmin and i stuck on “MySQL password”. In all videos i saw that field “Set MySQL password” is not empty. But my field was empty.

When i enter random password, or i use my root password… i get " Warning! Incorrect MySQL password".

If i tick “Override theroot MySQL password to match
arning! … shutdown failed : /usr/bin/mysqladmin: connect to server at ‘localhost’ failed error: ‘*Access denied for user ‘root’@‘localhost’ (using password: YES)’

If i run “Re-check Configuration”
MySQL does not appear to be installed and running on your system, or has not yet been set up properly in Webmin’s MySQL Database module. If your system does not use MySQL, it should be disabled in Virtualmin’s module configuration page.

I removed users and did some other changes…
Then i tried to reinstall with “sh install.sh --uninstall” and i expected that i will get clean install, but no… i am exactly where i was.

Can you explain how to Reset Virtualmin (or reinstall), so i can get clean install? I think from clean install will be easier to start, in case if i messed up something after my attempts to fix problems.

Operating system CentOS Linux 7.9.2009
Webmin version 1.962
Usermin version 1.812
Virtualmin version 6.14

Hello @jurgis and welcome to the community.

This is important: did you install Virtualmin through Automated Virtualmin Installation | Virtualmin on a fresh server - fresh as is newly installed OS with nothing else installed, particularly MySQL.

If not, you need to do just that.

Yes, on a newly installed OS.(CentOS 7).
And i did this way:

Now i am reinstalling OS. I will try CentOS 8.
But tell me what could went wrong with MySQL password?

Why that field in configuration was empty?

and again this MySQL Password field is empty:

EDIT: wait… i think i know what i am doing wrong…
In tutorial they select CentOS7 and Webmin + LAMP… and then on top they install virtualmin.

I reinstalled OS once more time, but this time only OS without any CP.

That’s tricky to get right. You should install just the OS, then Virtualmin via the automated install link that I have provided in the message above.

There are lots of low quality tutorials made by bloggers who write about too many subjects which makes it impossible for them to have an in-depth experience with any of the subjects that they write about. It is best to use only the official Virtualmin documentation to install and configure Virtualmin.

1 Like

Finally got it to work, but there is bug in configuration.
This time I saw password, but after pressing “Next” i got error:
DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: NO)
Then i canceled configuration and used this password to login in MySQL database server. Now everything is fine with databases, but i have another problem… i will create new topic.