[warn] module php5_module is already loaded, skipping

Have the error below:

Failed to start service :

Starting httpd: [Sat Sep 19 08:19:38 2009] [warn] module php5_module is already loaded, skipping

Server was working fine, took some Virtualmin backups from another server to this one (done this many times before) and Appache stopped working, (I didn’t realise at first, so no idea which server backup broke things) tried to restart and got the above error.

Researched the error message and found multiple places saying to remove a repeated line from http.conf

LoadModule php5_module modules/libphp5.so

The above line (or similar) wasn’t in that file, could only find it in php.conf, tried commenting it out but got

Failed to start service :

Starting httpd: [FAILED]

Running latest GPL version of Virtualmin under Centos 5.

Ran a Yum upgrade so everything is upto date.

Tried disabling the new servers I’d added to this server, but made no difference. I added aboout 8 domains, it looks like loading these backed up servers from another server broke something (the other server is working fine).

Server is out of action, most of my important sites are down!

Any ideas what to try next?


David Law


The PHP message you’re seeing is only a warning, it’s not the cause of Apache not starting.

You might want to take a peek in the Apache error log in /var/log/httpd/error_log.

Also, if you run “httpd -t”, do you see any messages in addition to what you already saw?

Lastly, before starting Apache again, run “ps auxw | grep http”, and make sure no Apache processes are already running.


Thanks for the point in the right direction.

Turned out one of the virtualmin servers I’d transferred accross had Google analytics installed, but for reasons I’ve not looked into stopped apache starting.

So I was looking for the wrong problem.

Thanks for the rapid response.

David Law