[warn] mod_fcgid: read data timeout in 31 seconds issue restored

Running VirtualMin on CentoOS 5.6 on Amazon EC2. Everything works perfectly, many thanks to VirtualMin developers.

However, there is a single problem I cannot find solution for. I’m having same issue as dkmortensen in http://www.virtualmin.com/node/19879 thread on entirely different system.

There is a maintenance (Drupal cron.php) script that takes around 50 sec. to execute.
After setting Server Configuration -> Website Options -> Unlimited Exec I can see httpd.conf is properly configured with line inside :

IPCCommTimeout 9999

After executing script there is error:
[warn] mod_fcgid: read data timeout in 31 seconds

Then after:
service httpd restart
Script executes with no problem in 56 sec.

Cron executes same script after 10 hours: [warn] mod_fcgid: read data timeout in 31 seconds

Again after service httpd restart script executes in 54 sec. with no problem.

Again in couple of hours: [warn] mod_fcgid: read data timeout in 31 seconds

I have spend 2 days searching for hidden mod_fcgid setting that could do that, but still unsuccessful.

Can anyone help?



Do you have the same problem when using CGI, rather than FCGID? You can change that in Server Configuration -> Website Options -> PHP Execution Mode.



No issue at CGI, but it’s slow. I can also configure cron as root and run script after httpd restart, but I’m kind a determined to help solve the issue and have it work as FCGID.

Just please help me find hidden conf where this is set. I’m sure it’s VirtualMin catch because of 31 sec. FCGID is 600 sec in default install.




When I try to change to CGI Wrapper, I get:
The requested URL /cgi-bin/… was not found on this server.

With any url File not found.

Tried cgi.fix_pathinfo=0, but same result.

I run PHP 5.2.17

Thanks for help