VPS moved - updates needed?


My hosting service just moved my VPS from one machine to another, i.e., the IP address changed. The one issue I am fighting is that I cannot access my website - when I try, I get the Horde login page.

Poking around, I foudn something suspicious and would like your guidance.

In Virtualmin’s Network Settings (in System Settings -> Virtualmin Config -> Network Settings), the first field is Network interface for virtual addresses. This has been manually set to venet0:0. I logged into my server using SSH and ran the ifconfig command. It returned four interfaces: lo, venet0, venet0:1, and venet0:2.

My first observation is that venet0:0 is not listed.

My second is that the value for inet addr for venet0:1 is the old VPS IP address and that the value for inet addr for venet0:2 is the new VPS IP. It seems to me that I should update the value of Network interface for virtual addresses to venet0:2 and that this may go a long way to resolving my problems.

Do this seem like a reasonable course of action?

Also, should I also delete interface venet0:1? If so, how do I do this?

More info: In Virtualmin->Server Configuration->Change IP Address, the IP address shown is the old IP address. I know that my server has moved because I use a Firefox plugin that shows me the IP address of the site being visited.

I also found Webmin->Netwowrking->Network Configuration->Network Interfaces. This also shows both the new and old IP addresses. I tried deleting the old, but after rebooting, it reappeared. I tried changing the IP address under Host Addresses, but the old one reappeared.

I did find a useful post from andreychek, https://www.virtualmin.com/node/21025, but I do not understand what is meant by ‘change the network interface’.

I think I resolved this. The only oddity is that System Information does not seem to respond in any reasonable period of time.

I spoke too soon - something is still wrong. I cannot send emails - they are piling up in the queue, but I can receive them. The IP address for my host in /etc/hosts keeps getting overwritten with the old IP address. I have tried Virtualmin->Addresses and Networking->Change IP Addresses, but this appears to do nothing.

System Information is very slow to respond and it reports the old IP address

Virtualmin->Server Configuration->Change IP Address: now shows the new IP address
System Settings -> Virtualmin Config -> Network Settings - Network interface for virtual addresses: points to the venet0:1 which is associated with the new IP address

Please help - this is critically important!

Virtualmin 4.16 gpl running CentOS 6.6


If your server is changing IP addresses, you would need to use Webmin -> Network -> Network Configuration -> Network Interfaces in order to update the IP’s for your network device.

Either that, or edit the network config files on the file system.

Once that is complete, then you can use Virtualmin -> Server Configuration -> Change IP Address in order to update the IP address that the domains you have installed are configured to use.


Some more information:

[root@admin log]# cat /etc/resolv.conf

But, when I tried nslookup , the command never returned

When I tried ping, there was 100% packet loss.

p.s. This is a critical problem as I need this server for business purposes. I am willing to pay someone to resolve this for me - this must be fixed ASAP!



I think I did as your suggested, but am still having issues.

Upon closer observation, I see the following in Webmin -> Network -> Network Configuration -> Network Interfaces:

venet0:0 OpenVZ (Virtual) Yes

venet0:1 OpenVZ (Virtualmin) Yes

Note that the type for the desired IP address is shown as Virtualmin, not as virtual. Could this be the problem? If so, what do I do to resolve it?

Is there a way to force the order of the interfaces, i.e., make the new interface venet0:0? I am concerned that if I delete venet0:0, that venet0:1 will become venet0:0 and this will break the system since Virtualmin->System Settings -> Virtualmin Config -> Network Settings - Network interface for virtual addresses: points to the venet0:1.

Again, some more information:

In httpd/log/error_log, I see the following warnings:

[Sun May 10 04:12:52 2015] [warn] NameVirtualHost old_ip_addr:80 has no VirtualHosts

[Sun May 10 04:12:52 2015] [warn] NameVirtualHost old_ip_addr:443 has no VirtualHosts

[Sun May 10 04:12:52 2015] [warn] NameVirtualHost older_ip_addr:80 has no VirtualHosts

[Sun May 10 04:12:52 2015] [warn] NameVirtualHost older_ip_addr:443 has no VirtualHosts

but, in httpd.conf, I see the following:

< VirtualHost new_ip_addr:80 >

This implies (to me anyway), that the old addresses are still stored someplace on the system

Some more information - I think I know what is wrong, but I haven’t yet figured out how to resolve the problem.

Using tcpdump, I captured packets as I tried to ping What this showed was that the source address is the old IP address, which explains why responses are not being received.

When I tried ip addr show, it lists both the old and new IP addresses (in that order).

I suspect that the system is defaulting to venet0:0, but I need it to use venet0:1 (or better yet, I should be able to delete venet0:0 and have current venet0:1 become venet0:0)

Again, this is a critically important matter and I am willing to pay to have someone fix this for me.

Okay - problem is mostly solved. I overwrote

/etc/sysconfig/networking/devices/ifcfg-venet0:0 with the values from ifcfg-venet0:1 and then I did the same thing in /etc/sysconfig/network-scripts. I then did a service network restart and am now able to resolve addresses.

The only issue that remains is that when restarting the network service, it reported

ringing up interface venet0: error in ifcfg-venet0:1: already seen ipaddr in ifcfg-venet0:0

Guess that i will now try deleting venet0:1 and we’ll see what happens.

(Actually, I will wait until someone here tells me that I can do this without fear of hosing my system)

This is very frustrating. I cannot seem to eradicate the old IP address from my system. Every time I reboot, it comes back. Where on earth can that %^^*&%$ thing be hiding???


You could always talk to your provider about the issue you’re seeing, they may be able to provide some assistance.

Is your system using static IP’s, or DHCP?

If it’s using DHCP, I wonder if your provider is still giving out the old IP address for some reason.



Thx. Static IP.

I noticed that at least one site, http://whois.domaintools.com, is still showing my old IP address. Is it possible that at boot time, there is a process that requests the IP address based on the domain name and then uses the value returned as the authoritative one?