Virutalmin hung creating server, now webmin won't start

Virtualmin for some reason never completed creating a new account. It just sat at a spinner for ten minutes, so I closed the window. Looking into the file system it had created files in it. Logging back into Virtualmin the new account did not show up.

I rm’d the files under /home/newaccount because newaccount didn’t show up at all in the GUI.

Trying to create it again resulted in

Failed to create virtual server : Failed to lock file /etc/webmin/virtual-server/names/ after 5 minutes

So i stopped Webmin, deleted the lock-file that was there, and tried restarting Webmin.

I now get

Failed to open SSL key /home/newaccount/ssl.key at /usr/share/webmin/ line 4403

That’s because it doesn’t exist. Obviously Webmin/Virtualmin is in some weird half state. Where does it store its user account list so I can remove the screwed up one and get Webmin back up?

I worked around it by cloning a different home direcotry into the defunct one. Webmin then restarted, showed the account, and I could delete it.

That was weird.