Virtualmin6 Installer - a few error messages

▣▣▣ Phase 3 of 3: Configuration Name "Pod::Usage::Formatter" used only once: possible typo at /usr/bin/virtualmin-config-system line 6. [1/23] Configuring AWStats [ ✔ ] [2/23] Configuring Apache [ ✔ ] [3/23] Configuring Bind [ ✔ ] [4/23] Configuring ClamAV [ ✔ ] [5/23] Configuring Dovecot [ ✔ ] [6/23] Configuring Firewall [ ✔ ] [7/23] Configuring MySQL [ ✔ ] [8/23] Configuring NTP ██▒▒▒▒▒Use of uninitialized value $clocksource in string eq at /usr/share/perl5/vendor_perl/Virtualmin/Config/Plugin/ line 35. Use of uninitialized value $clocksource in string eq at /usr/share/perl5/vendor_perl/Virtualmin/Config/Plugin/ line 38.

I actually don’t know how that will affect the performance but I thought you guys might want to see it. This is just a fresh install on Centos 6.9.

Still setting up the (mail) server, that’s all I have seen so far.


Others I found so far:

Error - Perl execution failed

Can’t call method “Sections” on an undefined value at /usr/libexec/webmin/jailkit/index.cgi line 12.

and python-argparse not installed by default (for LetsEncrypt)

No comment on this from anyone? The issue with step 8/23 is still present…

Check virtualmin log file for installation errors. It is in the same location with file.

I did a fresh installation of Virtualmin on CentOS 6.9 x64 and I did not find any issues. It could be a repo issue.

You can manual install webmin and virtualmin.

What should I look for in the log file? I can’t see any error…I believe what I saw was an output from the script, and not an error reported in the log.

Update: On another Ubuntu 16.04 build with a more recent kernel and setup than my initial test, it appears the script does run without any warnings.

I was able to install Virtualmin on Debian 7, 8, 9, Ubuntu 14.04, 16.04, Fedora Server and CentOS 6 and 7 without any issues. In my testing I used the actual installer and an old one from 2 years ago. Both worked fine. In my opinion you have packages missing and Virtualmin is not finding them. Do an update, add EPEL repository. There are tutorials for manual installations of Webmin and Virtualmin here:

Can you make them working?


Is there any particular reason why you are still relying on CentOS 6? CentOS 6 is pretty old now, and in fact is only getting “maintenance” updates at this time. You should really switch to CentOS 7, for which I’ve not had any problems with on dozens of installs thus far.

If these or other errors present themselves on a CentOS 7 installed system, please let us know. Supporting fresh installs on older distro version IMHO seems a bit of a waste of time. No offense intended.

Hey everyone,

This seems to be an ntpd issue from the OpenVZ host, still have to verify with my provider.

OK, so I used a 6.9 for testing on nginx. I have now reinstalled Centos 7 with LEMP stack and got the same error.

Is there anything time-sensitive software that virtualmin/webmin requires? If none, I can skip on this one.