Virtualmin Yum Repository Isn't Working

I am struggling to get the Virtualmin yum repository to work on a CentOS 7 EC2 instance that was provisioned ~4 months ago and configured using

sudo yum clean all Loaded plugins: fastestmirror, priorities Cleaning repos: base epel extras updates virtualmin virtualmin-universal Cleaning up everything Cleaning up list of fastest mirrors sudo yum -d1 update [Errno 14] HTTP Error 404 - Not Found Trying other mirror. To address this issue please refer to the below knowledge base article

If above article doesn’t help to resolve this issue please create a bug on [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.

Here are some of the things i have tried to resolve this issue:

yum clean all

yum clean all; rm -f /var/lib/rpm/__db*; rpm --rebuilddb

I tried editing /etc/yum.repos.d/virtualmin.repo to use https instead of http.

I have tried editing /etc/yum/pluginconf.d/fastestmirror.conf in various ways, including setting enabled=0 and adding to the end.

Nothing has worked. Please help me fix it.

Same. Trying to get past this as well.

There’s a problem with metadata differences between the two mirror servers that I’m sorting out…but, the folloing should always work to get new metadata (none of that other stuff is necessary):

yum clean all
yum update

If that doesn’t work, let me know…it’d be some other issue.

The problem I know about is that there are two different sets of metadata across the two mirrors, because metadata is generated on the server itself. This used to work, but newer createrepo versions generate metadata in uniquely named files now, so I need to sync everything instead of just pushing packages…it means my package publishing workflow needs to change. I’m working on it today. It just depends on which repo server your yum contacts that day (based on DNS) as to whether it gets the old server or the new.

Hello Joe,

yum clean all + yum update results in text similar to that from my original post. The long string of characters that prefix the file name in the path portion of the URL are different though.

Edit: It looks like the first mirror is failing, then the second one works. It is a little unsettling seeing that text every time.

It’ll be fixed shortly (maybe tonight, if everything goes easily). It’s odd that you’re seeing it regularly, though…on my servers, I only see it when it switches between the two different servers. I may be able to temporarily just sync the repo metadata (which might have issues of its own).