Virtualmin won't update via apt [Solved]

Virtualmin version: 6.03
Webmin version: 1.962
Operating system: Ubuntu 18.04
OS version: 18.04

I am having a problem with my Ubuntu server: it’s running a current version of Webmin, but an ancient Virtualmin. Both are working, but I would like to get to a modern Virtualmin version as well.

I tried the two tips in @Joe’s helpful answer (to update /etc/apt/sources.list and make sure the vm6 key is present) but no dice. [I also upgraded the server from 14.04 to 18.04, which solved the certificate problem of the original post.] Here’s what I see now:

$ sudo apt-get update
Hit:1 bionic InRelease
Get:2 bionic-updates InRelease [88.7 kB]
Hit:3 bionic InRelease
Hit:4 virtualmin-universal InRelease
Get:5 bionic-updates InRelease [88.7 kB]
Get:6 bionic-security InRelease [88.7 kB]
Fetched 266 kB in 1s (275 kB/s)
Reading package lists... Done

$ apt list --upgradable
Listing... Done

Note that apt-get update examines the virtualmin repo, but never finds a newer release. In the past, Webmin has been regularly updated when I go to the servers web/virtualmin page.

What else can I try to troubleshoot this? Many thanks.


Try the following:

  1. Remove all mentions of Virtualmin repo from /etc/apt/sources.list
  2. Create /etc/apt/sources.list.d/virtualmin.list file with the following content:
deb virtualmin-bionic main
deb virtualmin-universal main
  1. Run apt-get clean and apt-get update && apt-get upgrade

However, you could always upgrade manually with:

cd /root
apt-get install ./webmin-virtual-server_6.14.gpl_all.deb

Regrettably, the first suggestion didn’t work. Any thoughts?

(NB: see the following post for the solution)

richb@sea:/etc/apt$ pwd

richb@sea:/etc/apt$ more sources.list
deb bionic main restricted universe
deb bionic-updates main restricted universe
deb bionic-security main restricted universe multiverse
deb bionic multiverse
deb bionic-updates multiverse

richb@sea:/etc/apt$ more sources.list.d/virtualmin.list
deb virtualmin-bionic main
deb virtualmin-universal main

richb@sea:/etc/apt$ sudo apt-get clean
richb@sea:/etc/apt$ sudo apt-get update
Hit:1 bionic InRelease
Hit:2 bionic-updates InRelease
Hit:3 bionic InRelease
Hit:4 virtualmin-bionic InRelease
Hit:5 bionic-updates InRelease
Hit:6 virtualmin-universal InRelease
Hit:7 bionic-security InRelease
Reading package lists... Done

richb@sea:/etc/apt$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

But this worked…

Virtualmin is now at 6.14; Webmin is 1.962 THANKS!

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.