Virtualmin/webmin dashboard not working after SSL expired

This is a follow up of this other problem Let's Encrypt suddenly unable to renew certificates where I tried to renew an expiring certificate of the domain name and the subdomain that I used for logging to virtualmin/webmin.

The SSL expired just now and I can’t seem to do anything on the dashboard anymore. If I try to open anything or say, change the virtual server in the dropdown, I jsut get the following error:

Connection Lost
"Can’t establish a connection to the server at  **[](**

What should I do?


Yes, this issue can be annoying. It’s simple to fix it though.

At first, try connecting to your server as to see if it works without an error above, and if it does, then re-request certificate for troubled domains.

If you still experience an issue after all, try the following easy to follow steps:

  1. Open for edit /etc/webmin/miniserv.conf
  2. Remove all lines with entries starting with ipkey and ipcert matching domain you’re having an issue with
  3. Remove all certfile and extracas lines
  4. Find keyfile= and set it to /etc/webmin/miniserv.pem
  5. Restart Webmin - /etc/webmin/restart

@Ilia Thank you so much for the reply. However, @calport helped me fixed it and found out that the reason for this issue was because I added ipv6 address to the DNS a few months back and he just needed to set up the server to use ipv6.


Yes, correct but I was trying to help with this question.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.