Virtualmin virtual-server module version 6.17-3 released

Howdy all,

I’ve rolled out version 6.17-3 of the Virtualmin virtual-server module for all repos. This is a minor bugfix release, but a couple of the bugs it fixes are particularly annoying, so everyone should update ASAP. In particular, this fixes the "undefined check_domain_connectivity" error that caused a number of folks distress.

Let us know if you run into problems (in a new topic).

Cheers,
Joe

4 Likes

I tested something and Virtualmin doesn’t offer a newer version when I am on 6.17.
So I tried an installation it via dpkg, which worked fine. But Virtualmin wants to “update” back to 6-17 since it thinks to be an downgrade. Did I miss something or did something wrong?

No, I probably missed something. I had to do some script updates and I probably made mistakes.

I’m looking into it.

1 Like

Thanks. :slight_smile: If you need tests, I can help.

Fixed. Repos syncing now.

3 Likes

If 6.17 don’t work with repos. How can the new update be installed manually with the fix on CentOs 8.4? Download the install file again and reinstall? Will it overwrite existing setup etc

You can usually manually download the file from webmin.com (in this case: Webmin ) and then install it with the package manager after you downloaded it.

Ah yes thank you. Couldnt see 6.17-3 but 6.17 and got confused.

What do you mean? 6.17-3 is available in the repos for CentOS 8.

And, no, you should never use install.sh to re-install onto a production system!

My version says 6.17 pro and not 6.17-3 and there is nothing available in yum.

When I re check configurations it says down the bottom : The Virtualmin APT repository config file /etc/yum.repos.d/virtualmin.repo does not refer to software.virtualmin.com!

I did a yum clean all, yum update - no difference. As before I can see other updates but not 6.17-3 unless I already have it but reads 6.17. I assume the APT error message above is the reason I cant see the latest update.

So, don’t post that file publicly, as it contains your key, but something is wrong with it, and if it’s not checking software.virtualmin.com, it obviously can’t get new versions of our packages.

I used the Webmin Modules page to upgrade the Virtualmin module from version 6.16 to 6.17-3 downloaded from http://software.virtualmin.com/gpl/wbm/virtual-server-6.17-3.gpl.wbm.gz. This seemed to work properly, but the Dashboard then listed version 6.17 Pro, and functions failed because files referenced from the Pro version could not be found. Example failures are detailed below.

From Edit Account Plan:

ERROR — PERL EXECUTION FAILED

Undefined subroutine &virtual_server::list_resellers called at /usr/local/lib/webmin-1.981/virtual-server/edit_plan.cgi line 172.

From Edit Server Template:

ERROR — PERL EXECUTION FAILED

Undefined subroutine &virtual_server::list_resellers called at virtual-serverlib-funcs.pl line 15654.

I tried to open the Reseller List, which returned:

404
File not found — /virtual-server/pro/edit_newresels.cgi

I updated the Virtualmin module from the GPL module repository, so it seems that files from the Pro version should not be referenced or required.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.