Undefined subroutine &virtual_server::check_domain_connectivity called at /usr/libexec/webmin/virtual-server/virtual-server-lib-funcs.pl line 8068


System hostname daily4mative Operating system CentOS Linux 8.4.2105
Webmin version 1.981 Usermin version 1.823
Virtualmin version 6.17 Authentic theme version 19.83-2

Please am stuck here and I dont know what to do. This is just my first time of having issues with webmin.

Please anyone can help? Am new here please forgive if I failed any question rule.
I have tried to install virtual server just like I do before and towards the end of the process am greeted with below error " Undefined subroutine &virtual_server::check_domain_connectivity called at /usr/libexec/webmin/virtual-server/virtual-server-lib-funcs.pl line 8068."
Please who can help guide me on what to do from here? Thanks

Try re-installing Virtualmin package by running:

dnf reinstall wbm-virtual-server

The other work around, until it is fixed with 6.17-2, could be downgrading back to Virtualmin 6.16:

dnf downgrade wbm-virtual-server

Reinstalling 6.17 won’t do anything useful. The bug is in 6.17. We had a tagging mishap, where fixes went in, but a new release didn’t get tagged…so the build script built the wrong version. The new version will be available soon.

I expected that buggy version was quickly replaced and pushed to the repos, while 6.17-2 was being prepared.

Everything in the build scripts is based on tags. The 6.17 tag is of a buggy version. Rebuilding 6.17 would produce exactly the same package that’s already there (and it’s not a good practice to re-use versions). I’ve rolled out 6.17-3 with all of the fixes I’m aware of.

1 Like

I have decided to keep waiting until the fixed version is released. This is because I dont want to deal on luck as I am far from being an expert on this. I can wait. Thanks

The fixed version is released. Virtualmin virtual-server module version 6.17-3 released

Wow…Thanks for this news. Let me check and see if I can install now. Thanks once again.