Virtualmin virtual-server module version 5.06 released

Howdy all,

I’ve just rolled out Virtualmin virtual-server module version 5.06 to all repos.

Changes since 5.05:

  • Updated the phpMyAdmin script installer to versions, and, Roundcube to 1.2.3, MediaWiki to 1.28.0, Mantis to 1.3.6 and 2.1.0, Typo3 to 6.2.30, Wordpress to 4.7.2, Drupal to 8.2.6 and 7.54, NextCloud to 10.0.3 and 11.0.1, IONcube to 6.0.9, Joomla to 3.6.5, Node.js to 7.5.0, Piwik to 3.0.1, TikiWiki to 16.2 and 12.11, Dolibarr to 3.9.4, Moodle to 3.2, Magento to 2.1.4, SMF to 2.0.13, Ghost to 0.11.4, phpMyAdmin to and 4.6.6, ZenPhoto to 1.4.14, Revive Adserver to 4.0.1, Instiki to 0.20.1, and ownCloud to 9.1.4.
  • Added support for FPM as a PHP execution mode, on systems that have a system package which runs an FPM pool server.
  • Resellers and domain owners can be granted the ability to migrate backups from other control panels, like cPanel and Plesk.
  • Added a button to the Manage SSL Certificate page and a flag to the modify-web API command to break shared certificate linkage.
  • Added the start-stop-script API command to manage the servers behind Ruby and Node.JS scripts.
  • Virtualmin will now also generate SSHFP DNS records (for SSH host keys) when it creates TLSA records.

Note that PHP-FPM support is considered beta! It has had limited testing, and we recommend you try it in a non-production context first, before deploying to existing sites in production. Please report any bugs or confusing behavior. We haven’t written good docs for it, yet, but wanted to get it out there for people to start banging on it, as it is a big bunch of changes, and it’ll need a lot of testing before we’re confident it is solid. It will become the default execution mode for PHP apps in the next version or two.

There’s also an update to virtualmin-nginx to support FPM, as well, also in the repos today (getting its own announcement message).



Hi dev

Waiting support for MariaDB latest version.

i’ve submitted a bug against ubuntu complaining about licensing after upgrade to 5.06. the repos don’t have gpl versions anymore, but maybe that is on purpose? centos machines upgrading to 5.06 (with no gpl tag) aren’t complaining.

can you enlighten me/us if this is what should be happening?

@Joe you mentioned above: “There’s also an update to virtualmin-nginx to support FPM”

however PHP7-FPM working fine with Apache 2.4 too on Ubuntu 16.04… so far.

so… was FPM support, mainly for nginx? what about Apache?

FPM is supported for both Apache and nginx. The core Virtualmin module provides Apache support (it is not a separate module, as Apache support pre-dates the existence of the Virtualmin plugin API). To use nginx with FPM you need the new virtualmin-nginx module. For Apache, you just need the standard Virtualmin virtual-server module.

There’s been a third party installer that setup nginx with FPM in existence for a little while, but I have no experience with that project (but, I think it’s great that folks are building new things with/for Virtualmin!). This release is the first one we’ve done that has explicit support for PHP-FPM. It’s been possible to munge it in via Server Templates forever (literally, as long as PHP-FPM has existed, it could have been used with a Server Template and a post-create script, and some people documented doing that). But, this makes it easy and requires no knowledge of how things work behind the scenes. But, it is still beta. Very new code, not a lot of testing. If you need production ready stick with FCGId until we’ve banged on this some more.

I accidentally rolled the wrong package into the GPL repos (I ran my GPL repo sync script against the wrong thing). I’ve switched them in the repos, but we may need to roll a new version to make it upgrade to the right version on its own.

Apologies for the confusion. I suspect on Ubuntu/Debian systems, the new package will offer to upgrade automatically, but I know it won’t on CentOS, so we definitely have to roll a new version for that.

Jamie is rolling a new version with a Let’s Encrypt bugfix (I think it’s actually a workaround for an error that Let’s Encrypt is serving out, rather than a bug in Virtualmin, but I might be wrong about that), so that may be when all of this gets resolved for folks who were unlucky enough to get the broken update during the few hours it was available.

I think there’s a way to manually force a cross-grade to a specific package in apt-get, but I don’t remember what it is, off hand.

Are there issues in the ticket tracker about it? I don’t know of any problems, but I may not be running the latest version (we’re on some 10.x version).

Edit: and when I say “I”, I really just mean me. If there are tickets, or have been discussions with Jamie or Eric, I haven’t heard about them, but I’m sure they’re being worked on. Also, that wouldn’t be a Virtualmin issue, it’d be Webmin, which is where database support resides.

Hi sir joe,
Yes upgrade working for old DB, but can’t create new DB again. and can’t syncron database.

My problem with mariadb 10.x latest.

Hmm…is there a bug in the ticket tracker about it? I don’t see one in a cursory glance. Jamie needs to know about problems in order to fix them! So, file a bug, if you haven’t already, with the specific error you see. We use some 10.x version of MariaDB on and some others, and I haven’t seen problems, but maybe something new has happened in even newer versions. Anyway, if it’s causing problems, it’ll need to get fixed in the next Webmin release, so it needs a bug filed, if one hasn’t already been filed.

The previous update added lots of wonderful new install scripts to Virtualmin, including WordPress finally. Now, I’ve just installed the latest update, given the same version number as the last, and it has removed all of the new scripts. Thanks for nothing.

Hello, thanks for all your hard work!

If I may ask something, as a half-newbie, I’m confused as to how I may add PHP-FPM support.

In virtualmin, in /virtual-server/edit_phpmode.cgi , I still only have the usual three options, apache mod_php, CGI wrapper (run as virtual server owner) and FCGId (run as virtual server owner).

For a Debian Wheezy (7.3) using Apache, could I humbly ask how I could add Php-FPM for Virtualmin to recognize and allow it?
I’m perfectly fine with RTFMs, but I’m not even sure where to begin, which is why I come and ask.

That was a mistake on my part. I’m sorry for the confusion. Virtualmin 6 (coming pretty soon, hopefully before the end of the month) will bring several new install scripts over from Pro into GPL, though not all of them (they cost a tremendous amount of time to maintain, and we’re definitely ot making a fortune doing this).

You’ll need to install the php-fpm package (probably named “php5-fpm” on Debian/Ubuntu, but it’d be php-fpm on CentOS, but might also have more to the name, if a non-standard PHP version/package is installed). Once installed, the option should appear on the Website Options page along-side the other execution modes.

This package will be added to our default install list in Virtualmin 6, but anyone upgrading from older versions will need to install the package themselves (this can be done in the Webmin Software Packages module, or from the command line with apt-get or yum).

Thanks a lot Joe! I didn’t know if I had to look into standard packages, into apache modules and such… Much appreciated!

If anyone needs the bonus 20 seconds, that was:
apt-get update
apt-cache search fpm
apt-get install php5-fpm

Once installed, it was available in the website options section.

Ah, an error report. I experienced the problem after the bunch of updates this morning, that required to restart Apache.

On my server, Apache2 is unable to restart (or, once stopped, start) if PHP-FPM is the PHP execution mode of one or several of the virtual servers.

# service apache2 restart
Syntax error on line 40 of /etc/apache2/sites-enabled/
ProxyPass URL must be absolute!
Action ‘configtest’ failed.
The Apache error log may have more information.

On that line 30, there was:
ProxyPassMatch ^/(..php(/.)?)$ unix:/var/php-fpm/14217632198914.sock|fcgi://localhost/home/virtual_domain_name/public_html/$1

Additionally perhaps, I found it odd that the error I was displayed in shell (absolute URL req) was not logged anywhere in the system log files (not apache2/error.log of course, but neither system log or any other one listed by Virtualmin & Webmin), but maybe that has to see with my own Debian server.

And yet, it is entirely possible to switch any virtual server to PHP-FPM as long as Apache2 was already running.
In the meantime, I’m switching back to fcgid.

Server info: Debian Wheezy 7.3, PHP Version 5.4.45-0+deb7u7…
Feel free to reply if you want more testing or debugging. Or else, good luck fixing it :wink:

FPM working thus far on Centos 7 with php7.1. Wish there was a virtualmin module or screen to manage say php settings to each fpm pool or virtual server. That’s the biggest weakness I see thus far. That, and, minimum number of servers, etc.

Good ideas! I’ll put it on Jamie’s radar next time we talk. It’ll be a while, as he’s got other huge features on his plate right now, but it’d be nice to have.