Virtualmin virtual-server module 6.10 released

Howdy all,

Virtualmin virtual-server module 6.10 is in the repos. This is a huge update with some significant changes.

Changes since 6.09:

  • Added the set-dkim API command to enable and disable DKIM.
  • The compression format can now be selected on a per-backup basis.
  • Scheduled backups can have a descriptive comment for recording their purpose, which is also displayed in backup logs.
  • Per-domain SSL certifcates can now be setup in Postfix, if running version 3.4 or later.
  • Updated the SSL Certificate page to allow more control over per-domain certs for Webmin, Usermin, Postfix and Dovecot.
  • Many language updates.

In particular, this may fix the problem some folks saw in the past couple revisions where Dovecot became unpredictable on Let’s Encrypt certificate updates. It also adds SNI for Postfix, which is a bunch of code and a pretty new feature in Postfix, to boot, so it’s likely to be quirky for some folks in some situations…so, proceed with caution, maybe try it on a development server before you try to start using certs for every domain in Postfix.

As an aside, this release has all of the bits we’d planned in the Virtualmin module for Virtualmin 7, so in a few weeks the Virtualmin 7 installer and virtualmin-config package will arrive to enable the various new features by default, install some extra packages (and deprecate some others), etc.

Let us know if you have problems.

Cheers,
Joe

5 Likes

Adding new SSL virtual website …
… SSL website failed! : Undefined subroutine &postfix::regenerate_sni_table called at /usr/share/webmin/virtual-server/feature-ssl.pl line 2268.

You either didn’t upgrade Webmin or Webmin needs to be restarted. Postfix SNI needs version 1.953 of Webmin. It should have been in the dependencies for the module, but maybe that got missed.

ok debian only installs 1.942 when i do an update

Which repo? (I need the path from your sources.list for virtualmin-universal repo)

deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-buster main
deb http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main

Should be fixed now.

apt-get update; apt-get install webmin

1 Like

Hi there,

I have problems with install it on CentOS 8. I just get this error…

Failed with error: 1
[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
Warnung: /var/cache/dnf/epel-6519ee669354a484/packages/GeoIP-1.6.12-7.el8.x86_64.rpm: Header V3 RSA/SHA256 Signature, Schlüssel-ID 2f86d6a1: NOKEY
GPG-Schlüssel 0x2F86D6A1 wird importiert:
Benutzer-ID : »Fedora EPEL (8) epel@fedoraproject.org«
Fingerabdruck: 94E2 79EB 8D8F 25B2 1810 ADF1 21EA 45AB 2F86 D6A1
Von : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
Warnung: /var/cache/dnf/virtualmin-55ce78dff24b1c06/packages/jailkit-2.21-1.el8.vm.x86_64.rpm: Header V4 RSA/SHA1 Signature, Schlüssel-ID 60d62a6b: NOKEY
GPG-Schlüssel 0x60D62A6B wird importiert:
Benutzer-ID : »Virtualmin, Inc. (Package signing key for Virtualmin 6) security@virtualmin.com«
Fingerabdruck: E36F 0664 7D8E BD2B E364 2BCE D9F9 0107 60D6 2A6B
Von : /etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin-6
Error in PREIN scriptlet in rpm package wbm-virtualmin-awstats
Fehler: Transaktion fehlgeschlagen
Installing dependencies and system packages: [2020-07-13 19:08:38 CDT] [ERROR] Failed with error: 1
[2020-07-13 19:08:38 CDT] [ERROR] Something went wrong. Exiting.
[2020-07-13 19:08:38 CDT] [ERROR] The last few log entries were:

worked…

and did all tests… all seems to work now with this… gonna move some live testing domains to this, setup the clients and see if all works well with this :slight_smile:

Hello,

this version have support for Ubuntu 20? I just try and get this error:

▣□□ Phase 1 of 3: Setup

[ERROR] No repos available for this OS. Are you running unstable/testing?

Nothing in the changelog or message above said anything about support for Ubuntu 20.04 in the installer (which is a wholly separate bit of code with its own repos and releases that get announced when they are updated).

Luckily for you, I just rolled out the new install script and virtualmin-config package, probably with support for Ubuntu 20.04 (I haven’t tested it but Ilia tells me it’s there). I will be announcing, as I always do, in another news post :wink:

1 Like

Was this supposed to be

can now be setup ?

Yes, sorry, typo. Too many things in one day.

@Joe one small challange
Webmin:
Postfix Mail Server
Postfix version 3.1.14
but shell:
apt-show-versions | grep postfix
postfix:amd64/buster 3.4.10-0+deb10u1 uptodate

how to fix this one… ?

Okay, so you persuaded me to update Postfix. I’m really not all that expert in Postfix, so I’d been following the philosophy of “If it ain’t broke, don’t fix it” until now. But this gave me a reason, so I updated 2.10.1 to 3.5.3, which was much less painful than I’d anticipated.

The thing is that Webmin / Virtualmin still show the Postfix version as 2.10.1, but both postconf mail_version and postconf -d | grep mail_version show it as 3.5.3. It can’t be two instances because I removed Postfix before updating.

The mail is working fine, and the Webmin functions related to Postfix that I tested also work fine. Roundcube also works fine.

There is one minor glitch: /var/log/maillog showed an error about not listing the hostname in BOTH mydestination and virtual_mailbox_domains, which I fixed, whereupon the mail stopped working (“User unknown in virtual alias table”). So I broke it again, and now it works. I can sort that out later.

So basically, the only odd thing is that Webmin is not reporting the proper Postfix version. Any clues? (I did restart Webmin after updating Postfix. In fact, I rebooted the server, as well.)

Thanks,

Richard

The version number comes from /etc/webmin/postfix/version changed mine, but i just got new errors to get this working :slight_smile:

Ah, okay. Thank you.

Do you mean that changing the version number in that file caused the errors?

Richard

Okay, I solved the annoying warning by changing mydestination in main.cf to

mydestination = $myhostname, localhost.$mydomain, localhost

I thought I’d done that already, but I guess I was wrong. In any case, the warning is gone. I’m ecstatic because having been a long-time Exim user, the first time I messed with Postfix I hosed it so thoroughly that I thought I’d never get it working again.

I’m in my happy place now.

Richard

Webmin 1.953
Virtualmin 6.10 Pro
OS Centos 7.8.2003

I’m still having trouble renewing an SSL certificate with Let’s Encrypt.
The certificate renews but Dovecot fails to restart (post creation command failed).

Webmin screen…
Validating configuration for gscerb.xyz …
… no problems found

Requesting a certificate for gscerb.xyz, www.gscerb.xyz, mail.gscerb.xyz, admin.gscerb.xyz, webmail.gscerb.xyz from Let’s Encrypt …
… request was successful!

Configuring webserver to use new certificate and key …
… done

Post-creation command failed :

Applying web server configuration …
… done

Re-starting Webmin …
… done

Re-starting Usermin …
… done

● dovecot.service - Dovecot IMAP/POP3 email server
Loaded: loaded (/usr/lib/systemd/system/dovecot.service; enabled; vendor preset: disabled)
Active: failed (Result: signal) since Wed 2020-07-15 11:57:20 EDT; 34s ago
Docs: man:dovecot(1)
http://wiki2.dovecot.org/
Process: 1656 ExecStart=/usr/sbin/dovecot (code=exited, status=0/SUCCESS)
Process: 1653 ExecStartPre=/usr/sbin/portrelease dovecot (code=exited, status=0/SUCCESS)
Process: 1618 ExecStartPre=/usr/libexec/dovecot/prestartscript (code=exited, status=0/SUCCESS)
Main PID: 1704 (code=killed, signal=KILL)

Jul 15 11:54:19 host.markfernald.com systemd[1]: Can’t open PID file /var/run/dovecot/master.pid (yet?) after start: No such file or directory
Jul 15 11:54:19 host.markfernald.com dovecot[1704]: master: Dovecot v2.2.36 (1f10bfa63) starting up for imap, pop3 (core dumps disabled)
Jul 15 11:54:19 host.markfernald.com systemd[1]: Started Dovecot IMAP/POP3 email server.
Jul 15 11:55:40 host.markfernald.com auth[2590]: pam_unix(dovecot:auth): check pass; user unknown
Jul 15 11:55:40 host.markfernald.com auth[2590]: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=barlow930@markfernald.com…238.118.17
Jul 15 11:55:44 host.markfernald.com dovecot[1711]: imap-login: Disconnected (auth failed, 1 attempts in 7 secs): user=barlow930@markfernald.com, method=PLAIN, …qpeto7nYR>
Jul 15 11:57:19 host.markfernald.com dovecot[1704]: master: Warning: SIGHUP received - reloading configuration
Jul 15 11:57:20 host.markfernald.com systemd[1]: dovecot.service: main process exited, code=killed, status=9/KILL
Jul 15 11:57:20 host.markfernald.com systemd[1]: Unit dovecot.service entered failed state.
Jul 15 11:57:20 host.markfernald.com systemd[1]: dovecot.service failed.

That shouldn’t be happening. What is the content of Dovecot configuration file? Before and after requesting a certificate?