Virtualmin version says outdated but there are no updates offered


I use Virtualmin GPL (and it’s awesome).
My config is:
CentOS 7.7.1908
Webmin 1.941
Usermin version 1.791
Virtualmin 6.02

All my updates are done through Webmin, with yum.
Today I noticed that the Virtualmin version 6.02 is outlined in red and it says “This version is outdated”.
But, no new version of Virtualmin is offered in Software Package Updates; and since version 6.02 has been released quite a long time ago, I think that maybe I’m missing something.

When I check yum repolist I see the following repos
base/7/x86_64, centos-sclo-rh/x86_64, centos-sclo-sclo/x86_64, epel/x86_64, extras/7/x86_64, rhscl-rh-php56-epel-7-x86_64, updates/7/x86_64, virtualmin/7/x86_64, virtualmin-universal, webtatic/x86_64

Could somebody maybe point me in the right direction as to what could be happening here?

The wbm-virtual-server package is in the virtualmin-universal repo. Try doing yum clean all; yum update wbm-virtual-server

If that doesn’t do something, look for errors, particularly with the virtualmin-unversal repo.

Hi Joe,

Thank you for responding so soon.
I just ran the command and it gives the following message when it’s done:
“Package(s) wbm-virtual-server available, but not installed.”

Can I just install the package with yum?
When I installed Virtualmin I used the install script; it’s a little strange that this package is missing…

The only knows how to install with packages, so it had to have been removed at some point and replaced with, I guess, the wbm?

Is any Virtualmin module installed via RPM? rpm -qa|grep wbm-

I guess as long as Webmin was installed via RPM (rpm -q webmin), you’re probably OK to install wbm-virtual-server, but backup your /etc/webmin directory first. I think the same postinstall scripts run the same way for both RPM and wbm installs, but it’s going to think it’s never been installed so it’ll run some extra ones (probably harmless, but better safe than sorry).

Hi Joe,

Now you mention it, at some point in time, I think there could have been a replacement, yes, because there had been a diskcorruption due to a hardware failure.

When I run rpm -qa|grep wbm- I see this:

When I run rpm -q webmin I see this:

Do you think that there is any possibility in losing configuration when I install the package?