Virtualmin Update Fails

Hi all, I see on the system information screen that there is an update available. It is listed as

“clamav End-user tools for the Clam Antivirus scanner”

But when I click “Install All Updates” the update fails with the last few lines reading:

clamav-filesystem-0.95.2-1.vm.el5.i386 from virtualmin has depsolving problems
–> clamav-filesystem conflicts with clamav
Error: clamav-filesystem conflicts with clamav

… install failed!

Does anyone else have this problem or know how to fix it?


What do you get if you type:

rpm -qa | grep -i clamav

It sounds like your existing Clam packages may be conflicting with the ones being provided by Virtualmin – we may just need to manually uninstall what you currently have.




Yup, that’s what I’m after!

One more quick thing here – just to make sure it’s pulling from the correct repository, what do you get when you type this:

yum list updates



I assume you meant the first part of the output and not the actual list of package updates… but if I’m wrong I’ll be glad to list them here. In any case:

yum list updates
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Ahh, well, I wasn’t expecting a long list :slight_smile:

How about this – can you run this command:

yum list updates | grep clam

That should offer the info we need. Thanks!


clamav.i386 0.95.2-4.el5.rf rpmforge

clamav-data.i386 0.95.2-1.vm.el5 virtualmin

clamav-filesystem.i386 0.95.2-1.vm.el5 virtualmin

clamav-lib.i386 0.95.2-1.vm.el5 virtualmin

clamav-server.i386 0.95.2-1.vm.el5 virtualmin

clamav-server-sysv.i386 0.95.2-1.vm.el5 virtualmin

clamav-update.i386 0.95.2-1.vm.el5 virtualmin

Yeah, there we go.

It looks like you have multiple third party repository’s setup – and they appear to be conflicting :wink:

One of the Clam packages is coming from rpmforge, and the others are coming from Virtualmin.

That’ll cause some trouble :slight_smile:

If you don’t need the rpmforge repo, you might consider disabling that.


Got it.

For now, I just ran

yum --disablerepo=rpmforge* update

which I believe is a temporary disable, IIRC… either way, that worked. Thanks!