Virtualmin Tab Showing Only "Dashboard" Link

Operating system: CentOS
OS version: CentOS Linux release 7.9.2009 (Core)

I’m not sure exactly when this become an issue as I log into the web interface very little in general, however I’ve gone to create a new account on my server and found the Virtualmin tab contains no drop down or site/server controls whatsoever.

See this screenshot: Imgur: The magic of the Internet

I’ve tried a few things so far:

  • Tried different browsers
  • Ensured everything was up-to-date via yum update/upgrade
  • Installed latest release of usermin/webmin/virtualmin using the various scripts

All these things resulted in no change.

The issue I have is no error messages are being shown and I can’t seem to find anything glaringly obvious in the logs (if I’ve even found the right logs?).

Any help with this would be much appreciated!

Hello @Paraxial and welcome to the Virtualmin community forum.

This link has a solution to a similar problem:

Seems unlikely to be the exact same problem (that poster had to try real hard to screw up their system like that!). But, miniserv.error is the right place to look for a problem like this…it does seem apparent something disastrous is going wrong.

Never do this unless you really know what you’re doing, or you, specifically, have been told to do this by me or Jamie or Eric (Ilia, too, I guess, but he is a little too enthusiastic about recommending it for my taste…but, sometimes he knows about a bug that such an update will fix!).

Edit: And, I will probably never tell you to do it. I’ll try to fix it in a proper package.

Edit2: If it broke after using, I would assume that’s the cause of the problem.

1 Like


yum reinstall webmin usermin wbm-virtual-server

This turned out to be my issue.

I had indeed upgraded MariaDB previously, I thought in a sensible way, must have not been paying attention when it said Postfix was being removed as I don’t use any mail capabilities of my server.

Thanks for pointing me in the right direction, I didn’t even have the error messages he described in that post!

Glad it worked out for you. Cheers!

1 Like

If you aren’t using mail features, you should turn them off in Features and Plugins.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.