Virtualmin System-Hostname - why "127.0.0.1"

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Usermin version 1.860
Virtualmin version 7.3-1
Theme version 20.02
Package updates Alle installierten Pakete sind auf dem aktuellesten Stand

I wonder why I only see 127.0.0.1 at the sidebar for the "systemhostname,:

Where does this entry got it’s IP-Address from?

Another Server I’ve also installed show it in the right way with the external IP:

image

If you enter hostname , what does your system respond and what does it respond if you enter hostname -f

For both commands it returns the fqdn: xst02.xyz.com

Check Networking → Network Interfaces and its ipV4 address’ , click the ipV4 address that currently resolves in your hostname if that is set as is with the correct static config

Also check Networking → Host Addresses , here it should show 127.0.0.1 as localhost.localdomain, localhost and below that there should be listed the IP with the correct hostname.

I guess you have set the localhost IP here for the hostname

@croconx Sorry was afk for a while.
I’ve checkd now Check Networking → Network Interfaces and found it’s the right IP.
I have a failover-ip starting with 78.xx.xx.xx and the general IP of the Server itself is 49.xx.xx.xx.

Floating-IP is added like described here.

The Host-Addresses looks a bit strange to me.
There is no localhost.localdomain at all, and the third last line looks like a mixup with hostname and IP-Address

The entries for 127.0.0.1 that are showing xst02* shouldnt be correct, the entry with the 49* ip looks more correct and I think you have to enter the corresponding IPs to the hostnames.
127.0.0.1 should be nothing more than localhost, if you give localhost hostnames, of course they can appear as such then.

@croconx so what’s your suggestion with that?
Which one (from 1-10) should i remove or rename?

Server is nearly empty, as it’s a bare-metal installation.

The 49.x ip is only the general Server-IP, I do use the 78. as general IP as this is an Failover-IP.

I don’t know where does such strange hostnames like xst02-apache come from. Must be something Virtualmin created of it’s own

Well I just can guess, but for me it looks like this:

  1. is skippable since its disabled

  2. I would only list 127.0.0.1 one time with “localhost.localdomain, localhost, xst02-apache”

  3. not needed

4,5,6) leave as is

  1. not needed

8, 9, 10) you state a hostname for two different IPs + localhost again, a decision here would be more clear, wouldnt it ? And if u really need that hostname for 127.0.0.1 I would add it in 2) Not sure how to addthe second ip with the same hostname cause it is failover IP, is this IP always in your DNS entries listed as well ?

  1. then , 10 is not needed

i would give it at least a try, except you would have some special setup in your Routing and Gateways configuration

To make sure just list at least all unique hostname that is stated for 127.0.0.1 in one entry for 127.0.0.1 and it should be okay. Maybe it is needed for some special setup with nginx whatever, no clue. Never saw this after setting up a new virtualmin on a blank Debian server.