"Virtualmin>server configuration>suggested dns records" is suggesting an old static external ip address. How do i update this?

My server is on a google cloud compute instance, and i recently changed my static ip address (is was an accidental change that i thought would sort out a different problem i was having elsewhere…which it did not fix).

Just in case this may be relevant…I am hosting dns offsite using my registrars own nameservers…so am not using Bind and my own nameservers for any dns. Also, the google cloud network i think is providing internal dns…that is what i assume when looking at the automatically detected Webmin>Networking>Network Configuration>hostname and dns client (dns servers are shown as c.<my_google_cloud_project_name>.internal.google.internal

I have selected the “update hostname in host addresses if changed” checkbox in webmin>networking>networkconfiguration.

in shell, i have ensured that /etc/hosts has been updated to show the new external static ip address

Anyway, moving along to the fix…

How do i fix “virtualmin>server configuration>suggested dns records” to show the new static external ip address?

I think I had a similar issue when I had to move to a different VPS a couple of months ago. I’m fairly certain I sorted it out in either Virtualmin -> System Settings -> Server Templates or Virtualmin -> System Settings -> Virtualmin Configuration -> Default virtual server IPv4 address (manually set IP), then Default IP address for DNS records -> “Same as virtual server IP”. Might have been both places.