Virtualmin - Realm based Database Configuration - Bug

SYSTEM INFORMATION
OS type and version DEBIAN12
Webmin version 2.105
Virtualmin version 7.7
Related packages WEBMIN, SENDMAIL, VIRTUALMIN

When I create a Virtualmin Virtual Server for mail only for lets say acme.com
it by default creates a user called acme as my account name. Thats fine…
but when I create email users lets say stewart in the acme domain it creates an email
account which is stewart.acme… Now in general thats fine for mail delivery, but when I go
to authenticated via IMAP or POP3, I have to know that my login is stewart.acme instead of
just stewart@acme.com

So I think to get Dovecot to work like I want… I need the mail accounts created in a realm based format, and not what virtualmin is giving me…

So Since I know this isnt a restriction to Linux, and Sendmail as I can do it on my own…without virtualmin, I think this is in fact a virtualmin bug…

Any assistance would be appreciated…

THE SCREEN I AM REFERRING TO IN VIRTUALMIN IS UNDER - VIRTUAL SERVER CONFIGURATION
Change Domain Name - There you can modify it… but not to what I am requesting.

I am hoping to change the domain to @acme.com… and when I do it gives me an error…

This should work, I use @ in the user name. I think alot of complaints would happen if it didn’t.

when you edit user do you see @ in the username?

Is this a second question, create a new post if it is.

Yes thank you that should cover it… I appreciate your input.

Actually I tried it, and it doesnt work… its not the problem with the user sending or receiving email… its the Authentication realm for the user…You have to login to Roundcube or Dovecot as user.acme or user.acme.com so this is incorrect.

It is possible to do useradd stewart@acme.com and virtualmin should see it, but Virtualmin itself doesnt allow me to create the user that way.

Is it displaying as a @ in the edit user section like my screenshot, if your seeing a dot check the template settings under Mail For Domain

somewhere is a setting (I don’t have access to my systems at the moment) where you tell Virtualmin to use the @ syntax instead of the dot syntax for the “username”.

I do not recall if this is on a Virtual Server by Server basis, or is for the entire Virtualmin environment — ie, its a general setting for the entire server and all domains and Virtual Servers you create.

YES ---- Stefan1959’s post just above shows the exact spot !!!

Excellent thank you…that did the job… Thanks Stefan.

Jamey & Webmin —>you are amazing…you always shock me…

1 Like