Virtualmin quotas not work after upgrade

Hi there,

I’ve installed Virtualmin GPL about 2 months ago. When I’ve installed the system, everything works fine and this is my partition table:

/dev/sda1 /

/dev/sdb1 /home

/dev/sdc1 /var/log
/dev/sdc2 /var/lib/mysql

After I’ve upgraded to the new version of Virtualmin, quota says me: “Quotes are not turn on on /, that contains /home. Quotes modify are disabled”. Initially I’ve turned on quotas only in /home (rw, usrquota, grpquota) but not in /. Now I’m not able to use quotas and the quota that I’ve setting up was lost!

Someone can help me?!?!?!

Thanks

Howdy,

What is the output of the command “mount”?

-Eric

anastasia ~ # mount

/dev/mapper/vg-lv_root on / type ext4 (rw,errors=remount-ro) proc on /proc type proc (rw,noexec,nosuid,nodev) sysfs on /sys type sysfs (rw,noexec,nosuid,nodev) none on /sys/fs/cgroup type tmpfs (rw) none on /sys/fs/fuse/connections type fusectl (rw) none on /sys/kernel/debug type debugfs (rw) none on /sys/kernel/security type securityfs (rw) udev on /dev type devtmpfs (rw,mode=0755) devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620) tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755) none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880) none on /run/shm type tmpfs (rw,nosuid,nodev) none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755) none on /sys/fs/pstore type pstore (rw) /dev/sda1 on /boot type ext2 (rw) /dev/sdb1 on /home type ext4 (rw,usrquota,grpquota) /dev/sdc1 on /var/log type ext4 (rw) /dev/sdc2 on /var/lib/mysql type ext4 (rw) systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd) anastasia ~ #

I forgot to remember: before I do the upgrade, Virtualmin was working perfectly with quotas only on /home in a different disk. It’s just when I’ve upgraded that all quotas was losts and gave me that problem.

Howdy,

There were a number of fixes in the Webmin release that was just pushed out. Could you try upgrading Webmin, and see if that resolves the issue you’re seeing?

-Eric

Goodmorning,

thank you Eric to supporting me. Now I’m trying to update all the packages on the server, even Webmin even Virtualmin. Give me 2 hours and I’ll back with the informations.

Thank you so much

Hi Eric,

it doesn’t work yet. This is the output:

Checking Configuration
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 3.86 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
Il server DNS BIND è installato.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

Apache is installed.

The following PHP versions are available : 5.5.9 (/usr/bin/php5-cgi)

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin AWstats reporting is installed OK.

Plugin Mailman is installed OK.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

IPv6 addresses are available, using interface eth0.

Default IPv4 address for virtual servers is 95.110.155.185.

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

Default IP address is set to 95.110.155.185, which matches the detected external address.

Quote non abilitate nel filesystem / che contiene la directory home /home e i file email sotto /home. Modifica quote disabilitata.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… il tuo sistema è pronto per usare Virtualmin

I cannot edit my quotes.

Hi, no news for me?! I’ve tried anything but not working yet. How can I solve my issue?!