Virtualmin Pro & Cloudflare DNS error 7003

OS type and version Ubuntu server 20.04
Virtualmin version 6.17-3 Pro

The Cloudflare DNS integration seems to be broken somehow. When ever I try to open DNS records from Virtualmin, I get this error screen:

The error is: 7003 : Could not route to /zones/dns_records, perhaps your object identifier is invalid?, 7000 : No route for that URI

I’ve triple checked my Cloudflare global API key is correct in the Virtualmin settings, and the API key is working just fine on other services.

Any ideas? Ping @staff


Hi, I just would like to suggest you to mention virtualmin staff in your posts, since you are pro user you can rich guys directly. Mentions or notifications for anyone here works with @ and follow with group or user name… for example you can type @ staff (without space between @ and staff or users-name) and I am sure they will get your message and will pop in right after your message.

1 Like

Thanks @unborn

I forgot to ping the @staff in my original post, but did it now!

1 Like

Was this domain created successfully by Virtualmin on Cloudflare? If so, did editing DNS records ever work, or was it broken immediately after creation?

The site was created before enabling the Cloudflare DNS feature (like ~40 other sites I have in the Virtualmin enviroment). Re-creating all the sites is not an option :expressionless:

Unfortunately I don’t have a “spare” domain name that I could use for re-creation testing.

Ok, so you moved the DNS records from local hosting to Cloudflare?

Does this error happen for just this one zone, or all 40?

Hi @Jamie !

I’ve had the site’s DNS’s handled via Cloudflare prior to buying the Pro licence of Virtualmin (manually entered zone details via Cloudflare’s own admin).

Steps I did to make this error happen:

  1. Bought the licence for Pro version and activated it
  2. I enabled DNS service for Virtual server @ Virtualmin admin
  3. I chose to use Cloudflare as DNS hosting provider from Server Configuration => DNS Options
  4. I tried to make changes to DNS records through Virtualmin

Any tips how to take make Virtualmin to “talk” with Cloudflare with existing sites?

1 Like

Hi. I’ve actually been asking for CloudFlare support for years.

How is this enabled in V pro?

When I go to DNS Options for a Virtual Server I only see the option “local files”, nothing else.

If I enable this I can test it my end and help you with this thread.

Addresses and Networking->Cloud DNS Providers.

If you have further questions, please open a new topic so this one does not get hijacked with two unrelated conversations.

I added API key to a pre-existing Apache virtual server (DNS records already existed on CloudFlare for the domain), and got the same thing:

### 7003 : Could not route to /zones/dns_records, perhaps your object identifier is invalid?, 7000 : No route for that URI


  1. Added Global API key and my CloudFlare login to provider setup in V pro
  2. Added DNS feature to Apache virtual server
  3. Change from local files to CloudFlare DNS in DNS Options
  4. Click DNS records

Maybe this:


Seems this error is related to syntax?

or is it CloudFlare itself?

@MichaelMansour yep, exactly the same issue I’m having.

Ok, I’ve managed to re-produce this issue with Cloudflare - working on a fix now.


Ok, I’ve tracked down the cause of this issue, and will include a fix in the next Webmin release.

1 Like

Great news @Jamie!

Hi Jamie. I’ve just installed the update:


but when going to “DNS records” on the domain I enabled this on, I still get the same error as above.

So I thought about starting from scratch. On the Apache virtual server, moved back to local files, removed DNS feature, added DNS feature, go to DNS Options and selected Cloudflare DNS, got the error:

### Failed to save SPF DNS record : Failed to update DNS host : Failed to find zone for

(where “” is the actual domain that’s on Cloudflare).

Refreshed the web browser, back into DNS Options, showing the GUI page.

Go to DNS Records:

### 7003 : Could not route to /zones/dns_records, perhaps your object identifier is invalid?, 7000 : No route for that URI


Apologies, my previous status update was incorrect - the fix will be in the next Virtualmin release, not Webmin.

Any ETA on the fix?

Please expect the fix in upcoming Virtualmin 7 release.

1 Like

I’m getting the same challenge, same or similar situation. Domain name was manually managed via CloudFlare and now I’ve flipped it to CloudFlare but I can’t update DNS records, Reset the BIND DNS via Verification, or any other method.

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.991
Usermin version 1.840
Virtualmin version 7.0-4 Pro
Theme version 19.91.2
Package updates All installed packages are up to date


@staff is there any chance I could get a good workaround on this? I can’t just remove the domain and re-create it on my server, the domain name that I’m working with is my business domain.