Virtualmin Pro : Cannot download repomd.xml


Rocky Linux 8.6
| Webmin version | 1.999 |
| Virtualmin version | 7.1 |

I am trying to upgrade a system to Pro. I entered my key info into the Virtualmin Upgrade to pro and got an error. It does show as registered when inputting virtualmin license-info

So, I thought I’d do a update to see if any repos need to be updated. From the console, I get:

yum update
Virtualmin 7 GPL - noarch 295 B/s | 233 B 00:00
Errors during downloading metadata for repository ‘virtualmin-noarch’:

  • Status code: 404 for https://(proper serial #):(proper key #) (IP:
    Error: Failed to download metadata for repo ‘virtualmin-noarch’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Any advice on how to fix this?

That URL is wrong (there should be a pro or gpl in the repo path between 7 and rpm).

I thought this was fixed, though. @ilia are we still waiting on this fix to go into the Virtualmin package? Or is there some other explanation for why this is using the wrong URL?

We are still waiting. As Virtualmin 7.1.1 has never been released, it will go to Virtualmin 7.2.

The work around for now is to fix repos manually or use pre-release version of Virtualmin 7 install script and run it with --setup param, to fix repos and exit.

This is a fully operational server that I wish to upgrade to Pro. I don’t believe it is recommended to run another script.

How do I fix the repos manually?

The easiest and cleanest way to do it is to grab Virtualmin 7 pre-release install script and use it to setup repos and exit, i.e.:

wget -O
sh --setup

Yes, re-running install script is highly not recommended, unless you use it with --setup param to re-configure repos and exit.

Thank you @Ilia. That worked! This one is showing Pro and Pro features now.

And BTW, you guys are doing great with new features being added. I really like many of those.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.