Virtualmin / Postfix / Mailman - Only Delivering Local Mail


I’ve installed Virtualmin on CentOS 5.7 (I think), and spent ages tweaking my install.

I’m trying to use ‘Mail Aliases’ and Mailman Mailing Lists for the same purpose - to create a ‘’ mailing list, so I can send one email to multiple people. The distribution group consists of some local email addresses such as but mostly of ‘non-local’ domains such as and

When I setup either an Alias or a Mailman Mailing List, mail is delivered to local email addresses but not to the external one’s?

I tried following the guid here (,mail_relaying_with_virtualmin/) but this only seems to pass mail on from my server to be delivered by another - not what I want.

Can anyone tell me or point me in the direction of a guide that will show me how to configure Postfix to deliver mail to external domains when sent as part of a mailing list?

Thanks in advance,


Well, by default, you should be able to send email to someone at another mail server.

Is it possible that your ISP is blocking port 25 traffic?

One thing you could do is review your mail logs in /var/log/maillog, to see if anything related to your problem is being put in there.

You should be able to see any email that’s sent, and follow what’s happening to it. Also, if there’s any errors in Postfix, those should show up there as well.


Hi Eric - thanks for your response.

I tweaked a few settings. I’ve also tried what you suggested, and get the below when I try to send to a mailing list created in virtualmin (i get this delivered to the email account I try to email the mailing list from):

Delivery to the following recipient failed permanently:

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 Relay access denied (state 14).

I’ve chcked and the outgoing port 25 and it appears to be open.

From looking at the above, can you think of where it might be going wrong?

Thanks in advance.

Whenever you try to send yourself an email from Gmail, what shows up in your mail logs? Do you see a connection attempt? If so, what errors do you see there?


Thanks for your comments guys.

I’ve aquired a new VPS, running a clean install of Ubuntu 10.04.

I’ve installed Virtualmin and appear to be able to add a new domain, and create an email address for the domain and am able to send to and from this domain fine.

However, if I attempt to add a used and not deliver mail locally, but instead, forward the mail onto my account for example - the email never arrives.

Out of the box, what steps are necessary to configure postfix to allow relaying to external email addresses?

However, if I attempt to add a used and not deliver mail locally, but instead, forward the mail onto my account for example - the email never arrives.

It sounds like the Mail for Domain feature may be enabled.

If that’s enabled, it will try to deliver mail locally.

You can disable that by going into Edit Virtual Server -> Enabled Features.


Thanks Eric - I’d like to use a mixture of both, is that not possible?

I’ve added a domain and created 3 email addresses.

If I send an email to ‘’ it gets delivered locally.

If I add a local address (e.g. to the ‘Edit User > Email forwarding settings’ the email gets delivered correctly.


If I add my address to the ‘Email forwarding settings’… the mail gets delivered locally but not to my Gmail account.

Yet again, it appears postfix doesn’t want to forward mails to external domains?

** UPDATE **

I disabled my firewall and tried again, but still the mail to the ‘external’ domain doesn’t get delivered.

I can’t actually believe this, but I think the external mail delivery was failing because I was sending the test emails from gmail, and trying to send get it forwarded to gmail.

Pesky gmailers!

Thanks again for all your help