Virtualmin package update failed

[root@server ~]$ sudo yum -y update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile

  • base:
  • epel:
  • extras:
  • updates:
    Resolving Dependencies
    –> Running transaction check
    —> Package nss-softokn-freebl.i686 0:3.14.3-18.el6_6 will be updated
    —> Package nss-softokn-freebl.i686 0:3.14.3-19.el6_6 will be an update
    —> Package wbm-virtual-server.noarch 0:4.13.gpl-1 will be updated
    —> Package wbm-virtual-server.noarch 0:4.13.gpl-2 will be an update
    —> Package wbm-virtualmin-awstats.noarch 2:4.9-1 will be updated
    —> Package wbm-virtualmin-awstats.noarch 2:5.1-1 will be an update
    —> Package wbm-virtualmin-dav.noarch 2:3.5-1 will be updated
    —> Package wbm-virtualmin-dav.noarch 2:3.7-1 will be an update
    —> Package wbm-virtualmin-init.noarch 2:2.4-1 will be updated
    —> Package wbm-virtualmin-init.noarch 2:2.5-1 will be an update
    —> Package wbm-virtualmin-mailman.noarch 2:6.2-1 will be updated
    —> Package wbm-virtualmin-mailman.noarch 2:6.3-1 will be an update
    —> Package wbm-virtualmin-svn.noarch 2:5.0-1 will be updated
    —> Package wbm-virtualmin-svn.noarch 2:5.1-1 will be an update
    —> Package wbt-virtual-server-theme.noarch 2:8.7-1 will be updated
    —> Package wbt-virtual-server-theme.noarch 2:9.0-2 will be an update
    –> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

nss-softokn-freebl i686 3.14.3-19.el6_6 updates 156 k
wbm-virtual-server noarch 4.13.gpl-2 virtualmin-universal 2.2 M
wbm-virtualmin-awstats noarch 2:5.1-1 virtualmin-universal 43 k
wbm-virtualmin-dav noarch 2:3.7-1 virtualmin-universal 27 k
wbm-virtualmin-init noarch 2:2.5-1 virtualmin-universal 25 k
wbm-virtualmin-mailman noarch 2:6.3-1 virtualmin-universal 46 k
wbm-virtualmin-svn noarch 2:5.1-1 virtualmin-universal 48 k
wbt-virtual-server-theme noarch 2:9.0-2 virtualmin-universal 2.3 M

Transaction Summary

Upgrade 8 Package(s)

Total size: 4.9 M
Downloading Packages:
error: rpmts_HdrFromFdno: Header V3 DSA/SHA1 Signature, key ID 11f63c51: BAD

Problem opening package wbm-virtual-server-4.13.gpl-2.noarch.rpm

I did try to import virtual min key but still faied.

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin

Any help?

Thanks in advance.


While I hadn’t run into this myself, I saw a mention on twitter recently saying that the nss related CentOS packages had caused someones RPM database to become corrupt. I’m wondering if that may be what happened in your case.

What if you try manually installing one of those packages… say, wbm-virtualmin-svn, which you can do with this command:

yum install wbm-virtualmin-svn

What output does that produce?


Eric is right.
nss-softokn breaks yum/rpm in CentOS 6
In order to fix it do the following:


rpm2cpio nss-softokn-freebl-3.14.3-19.el6_6.x86_64.rpm | cpio -idmv

cd lib64

cp libfreeblpriv3.* /lib64

yum update

You may check this topic:


Thanks a lot! This solved my problem.

Thank you VERY much!.

Thank you!

:slight_smile: Priceless.

Just thought I would post a precaution for those who experience this problem: Do NOT run the command rpm --rebuilddb at any time until the problem is fixed as it’s explained above. By running rpm --rebuilddb without first fixing the problem will corrupt/destroy your rpm database and you’re left with no rpm database which can be a pain to restore it back especially if you have to do it manually. I know, I speak from experience. :slight_smile:

going to re-iterate :

“Thank you VERY much!.”

Thanks! This fixed the problem on Centos 6.6… wish I would have found this thread much sooner…

Thanks! This fixed the problem on Centos 6.6… wish I would have found this thread much sooner…

This has worked well for me on CentOS Linux 6.6

Thank you so much

So I waited WAY too long to discover this thread :frowning:

And now I do, the wget mirror above no longer works for the nss-softokn-freebl package…

My situation is just as described above, but I don’t know what to do, as I can’t seem to find the updated -freebl package on any mirror!

—> Package nss-softokn.x86_64 0:3.14.3-19.el6_6 will be updated
—> Package nss-softokn.x86_64 0:3.14.3-22.el6_6 will be an update
—> Package nss-softokn-freebl.x86_64 0:3.14.3-18.el6_6 will be updated
—> Package nss-softokn-freebl.x86_64 0:3.14.3-22.el6_6 will be an update

I’ve tried changing the number in the link above from “19” to “22” but it’s still not found.

Does anyone know how I should proceed here? Sorry I don’t know my way around Yum or RPM, but my yum updater is definitely broken with all the symptoms in this thread! I’m running CentOS Linux 6.6 with Virtualmin 4.13.gpl GPL

I found help on the CentOS forum here:

If anyone finds this thread, the actual wget link to use now is this (because CentOS 6.7 has been released and the 6.6 files have been moved to