Virtualmin Outlook Certificate error

OS type and version: CentOS Linux 7.9.200
Webmin version: 1.995
Virtualmin version: 7.1|
Related packages: SUGGESTED
Kernel and CPU: Linux 3.10.0-1160.71.1.el7.x86_64 on x86_64
Usermin version 1.850.
Everything is up to date.

I am currently trying to setup a Virtualmin in order to migrate 120 websites (wordpress with a lot of emails) from dedicated server with cPanel to three VPS servers with Virtualmin on it. There are 1.5 TB of data on dedicated server, emails mainly.
Idea is to cut expenses because dedicated server is far too expensive, cPanel too. I am the only admin that is accessing administration, so I do not really need cPanel.

For the last 7 days I have been trying to setup one VPS with Virtualmin, and so far so good. I’ve managed to setup backups incremental, and FTP backups. Tried restoring them too. All works great.
Redirected webmail .domain .com to domain .com/roundcube and it too works good. Sends and receives emails. DKIM SPF works good too. I’ve installed PHP from 5.4 to 8.1 (I have some websites that are old and require older PHP). I am using PHP FCGI.
Migration tool from cPanel to Virtualmin also works good. Sometimes I have to delete htaccess file, rename database etc. but it is manageable.

Also I have set up Let’s Encrypt SSL certificate and installed it on hostname, mail, admin, autoconfig, autodiscover, domain .com, webmail and www. And the clicked “Set as Default Services Certificate”.
Domains are emailmarketing .ba (server1 .emailmarketing .ba is hostname), tarcukovic .ba is second account I have setup in order to test Virtualmin and set it up. tarcukovic .ba also has SSL certificates installed.

My main concern is Outlook. When I restore cPanel account, all email accounts are present with their emails. But, as soon as I try to connect Outlook to any email (except host domain email) it does not recognize certificate. Ive tried this with Outlook 2007, 2010, 2016, 2019, from my PC and from two other computers. Same issue. Thunderbird does not have this issue.

I have Apache, BIND DNS, Dovecom Imap/Pop3 server, MariaDB, Postfix Mail Server, SpamAssassin, ProFTPD FTP server, SSH Server installed

Any help or idea is welcome.

Thank you!


Here is Outlook 2019 error:

Use the hostname of your Virtualmin system as the incoming server and outgoing server in Outlook 2019. The OS that you use does not offer much support for SNI.


On Virtualmin systems I always get my customers to use the Virtualmin hostname as incoming server and outgoing server of the email client rather than IMAP.clientgomain.tld and SMTP.clientdomain.tld that is the norm.

I have 120 customers who have incoming and outgoing servers:, and so on. I can’t go on hundreds of computers and mobile phones telling people what to do. I will lose customers this way.

I need Virtualmin to use,, and so on as incoming/outgoing server without SSL certificate error.

Is there a possibility like that with Virtualmin?
Maybe to use Sendmail instead Postfix?

Thank you


The issue here isn’t what is possible for Virtualmin to do, the issue is to what extent the OS and mail servers that you are using have support for SNI.

If you install Virtualmin on the latest Ubuntu LTS instead of C7 - released in July 2014 - then you may get different answers to your question about what Virtualmin supports.


Just to clarify, as @calport has been saying, it’s Postfix (SMTP) server which depending on the version doesn’t support SNI…

Do you know which version of Postfix you have installed, as more recent versions did introduce SNI support which could address your issue, however again it does need to be a more recent version so depending on your distro, version and such you may need to take @calport’s advice in the immediate future.

*** Professional, Affordable, Virtualmin Support ***

My Postfix version is 2.10.1

I’ve been trying to make Sendmail instead Postfix but i’m stuck now. It won’t start service.
This is error i get: Failed to save enabled features : The plugin Mail Relay cannot be used : The MIMEdefang process is not running on your system. Maybe it is not installed, or has not been started.

Don’t use Sendmail in 2022. Just use any modern distro, not CentOS 7 and you’ll be fine.

Is there any possibility to make Virtualmin to use as incoming/outgoing server for domain I would put in server, and then second account to use and so on.
I can’t user same incoming/outgoing server for every account I create.

I am migrating 120 websites from cPanel and cPanel has different incoming/outgoing server for each domain. I need it to work like this, if possible


This isn’t a limitation of Virtualmin, it’s a limitation of the SMTP server (Postfix) and the version you are using. Later versions did introduce SNI which supports multiple certs per single IP address.

How do I install newer version of Postfix?


That’s outside the scope of Virtualmin forum, however basically you’ll need to check if your distro supports a newer version easily, or compile a newer version. Sometimes there are repos which can be added to your distro to support newer versions of software.

If you really don’t know how to do any of this, I’d recommend hiring someone to do it for you.

I’d definitely recommend upgrading to a newer distro and version as most newer versions out of the box support newer software versions.

I am not sure if this is a dumb question, but what if I install Almalinux 9 on server with Webmin/Virtualmin?
Would I be able to have newer version of postfix with Virtualmin?

Depends all on your OS package not vmin.

I’ve installed Virtualmin 7.1 beta, with auto installer script, on AlmaLinux 8.6 and moved one website with 380 emails on it. So far I have no problems with Virtualmin. Postfix version is 3.5.8 and it is using as incoming/outgoing server.

Does anybody know how can I rewrite from field in sent emails from roundcube? For example I am having as email. When I send it to somebody in his inbox name is with email I would like to rewrite this - to @. This does not happen if I send email with Usermin. Also I have noticed when I login into roundcube the identity field has display name with “-” not with “@”. How can I fix this?

I’ve managed to do the change via phpmyadmin in table idenitites via search and replace, but if there is better solution I would like to do it

I solved using a wildcard certificate “*,” and applied to all services.
System: Ubuntu 20.04.4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.