Virtualmin on Windows 10 wls2?

Hi, Im new with this
Will it be possible to use the install script also on ubuntu 20.04 on windows 10 wls2?

Probably not. And, probably not advisable even if it does work.

The install script is designed around a use case quite different from a personal desktop/laptop. You probably don’t want all the things Virtualmin sets up to be setup on your workstation.

What’s the goal? Do you just want a Virtualmin development environment? Or are you actually trying to host websites on your Windows machine? If the latter, why?!?!

Setting up a virtual machine and using the install script is probably the best bet, if you don’t have much experience with the various tools involved and you want a local installation that matches your real web server(s) configuration for development.

Hi Jo
THX for taking care
I want to set up a Server to run Nextcloud websites and a project management tool at first.
In productive mode.
I now have set up an VMware machine on win 10 and Ubuntu 20.04 desktop.
PLS tell me where to download the right Virtualmin setup for this configuration.
If possible also an HowTo instruction
Hope for further help for the download.
For the rest: .

THX But under
Ubuntu 20.04 desktop is not listed!

Will It work?

It works with Ubuntu 20. It was mentioned, its more a beta state than a final state. But that information is a bit older.
However, you should make sure to use a server version (cli) of Ubuntu. Its not (most of the cases) recommended to use a GUI in a server environment (except Windows).

I tried on Ubuntu 20.04 Desktop:
ubuntu@ubun2004:~$ wget
–2020-08-23 11:53:46--
Auflösen des Hostnamens ( …
Verbindungsaufbau zu (||:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 32168 (31K) [application/x-sh]
Wird in »« gespeichert. 100%[===================>] 31.41K --.-KB/s in 0.05s

2020-08-23 11:53:46 (677 KB/s) - »« gespeichert [32168/32168]

ubuntu@ubun2004:~$ sudo /bin/sh
2020-08-23 11:54:10 URL: [22148/22148] -> “” [1]

Welcome to the Virtualmin GPL installer, version 6.1.1

This script must be run on a freshly installed supported OS. It does not
perform updates or upgrades (use your system package manager) or license
changes (use the “virtualmin change-license” command).

The systems currently supported by are:

CentOS/RHEL Linux 6, 7, and 8 on x86_64
Debian 8, 9, and 10 on i386 and amd64
Ubuntu 16.04 LTS and 18.04 LTS on i386 and amd64

If your OS/version/arch is not listed, installation will fail. More
details about the systems supported by the script can be found here:

The selected package bundle is LAMP and the size of install is
full. It will require up to 650 MB of disk space.

Exit and re-run this script with --help flag to see available options.

Continue? (y/n) y


Virtualmin may already be installed. This can happen if an installation failed,
and can be ignored in that case.

But, if Virtualmin has already successfully installed you should not run this
script again! It will cause breakage to your existing configuration.

Updates and upgrades can be performed from within Virtualmin. To change
license details, use the ‘virtualmin change-license’ command.

Changing the license never requires re-installation.

Really Continue? (y/n) y
[INFO] Started installation log in /root/virtualmin-install.log

▣□□ Phase 1 of 3: Setup
[ERROR] No repos available for this OS. Are you running unstable/testing?

Whats wrong?

You should take a look at what was written already. :smile:

Install worked perfect on Server version!
But Now?
How to get access to the file system to upload directory for website files
I normally use FileZilla

I think you should read the documentation, it seems that you dont really know much of it. Its not a problem, but you should really do it (also in terms of security): .

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.