Virtualmin on Lubunru 14.04

I know that Lubunru 14.04 is not on the list of 'Grade A supported Operating Systems" but I started a clean installation of Lubuntu 14.04 and the Virtualmin installation went smooth as if it was a regular Ubuntu 14.04. One of the problems I’m having is that I can not change the upload_max_size, even after changing it on /etc/php5/apache2/php.ini, /etc/php5/cgi/php.ini and /etc/php5/cli/php.ini. phpMyadmin keeps showing (Max: 2,048KiB) in the import file section. any ideas please? I can’t import my databases.

BTW I also changed, memory_limit and post_max_size, but no luck.

Thank you for any help provided.


You may want to try updating that particular user’s php.ini file, located in $HOME/etc/php.ini. That’s what would be used by default.

The other files you edited are the templates used for other domains that are created, so new domains would have the values you set.


Howdy andreychek, thx for the response, that did the trick. So is it save to say that even before u create virtual server, it is a good practice to edit all php.ini files? (sorry about my ignorance, Im lerning all this now.

now that i manage to change the max_upload_size , a new problem came along, my data base is 17MB in size and it seems that trying to import the database i get a 500 error (i guest is for not enough time to import). ca you help?

I do have Virtualmin install on another hard drive running Ubuntu 10.04, i wonder if I can just copy all those config files and transfer them to this new installation in Lubuntu 14?

Thx again Eric


It’s not necessary to make changes before creating any Virtual Servers, though you certainly can. It’s no problem to make updates after the Virtual Servers have been created.

If you don’t want to have to edit multiple files, you can make a change to all existing Virtual Servers using the Virtualmin command line tools. You can do that with a command like the following:

virtualmin modify-php-ini --ini-name max_upload_size --ini-value 50M

You can try copying those php.ini files to another distro – I’d test it on just one domain first, to make sure they don’t contain any PHP parameters that aren’t compatible with that version.

Lastly, you may want to increase the script run-time. One way to do that is in Server Configuration -> Website Options -> Maximum PHP script run time.


As always Eric, Thank you for your great support. I will try that as soon as possible and report back.



Thank you Eric for your help and support, what you suggested work.

I now need to learn how to backup all settings and configurations in case I mess up something that would make me start fresh.