Virtualmin Not pointing to the desired webpage after update

I have a virtual server setup on my aws system running ubuntu. The domain for my server is, everything was working fine until i ran the command do-release-update on my system and upgraded my OS from Ubuntu 14.04 to 16.04
Now as Ubuntu 16.04 uses php 7 i upgraded to that too.
Now my Apache server is running perfectly allright, also when i recheck configuration on virtualmin it gives me no error.
However when i try to access my domain it just prompts me to download a random php file.
Please help me solve the issue.
Also when i enter my IP in the URL bar instead of the domain the Apache configuration pages comes up perfectly and it runs php there properly.
Has anyone else updated and come across with the same issue ?
Please help me out urgently, my website is down and i have no clue on how to fix this.

Ronak Shah

Any help on this ? No-one got the same error while updating to Ubuntu 16.04 ?

Sorry for creating duplicate thread. See the issue here