Virtualmin Letsencrypt guide?

Is there one anywhere?

I tried it and it seemed to work, but going to the site via https throws up errors with Firefox - are there additional steps we need to carry out? Is there a guide anywhere?

Please provide more information. What error is shown? How did you set up letsencrypt?

It’s the standard FF error:

Hence I wondered whether I have done something wrong or missed anything out. Is there anything like a step-by-step guide anywhere?


The next release is going to add an additional CA certificate to Lets Encrypt certificates which can fix an issue like the one you’re describing.

In the meantime, you might want to try adding the contents of this file here to the end of the file in your domain’s homedir:

Just copy and paste that to the bottom of the file, and then restart Apache.

That will all happen automatically soon though.


Thanks Eric, that worked!

I updated to 5.02 and manually renewed the Lets encrypt Cert. Since the chain changed from X1 to X3 the chain was broken. The new CA X3 was not updated automatically.

Thanks Eric, been tying to figure out where I went wrong in installing letsencrypt since I did not compile it and instead used a repo to install. Things worked but multiple errors fired in Virtualmin then it went away. The error makes no sense since the SSL encryption can work without issue.

It never reached my mind to check file and add the change manually.


Thanks it works