Virtualmin labels and texts disappeared after 7.0 update

OS type and version Centos 8
Webmin version 1.991
Virtualmin version 7.0 Pro
Related packages none


After 7.0 latest update, cleared browser cache and refreshing theme cache in Webmin, mostly of labels and texts have disappeared from Virtualmin interface only (all good for Webmin interface).

Thank you in advance for your help.


Happening for me too.

Same here.

Already tried:

  • Restarting Webmin.
  • Logging out and back in.
  • Restarting server.
  • Logging in from another browser that I never used for Virtualmin before.

No joy.

Everything seems to be working in terms of web, mail, ftp, etc. The problem appears to be limited to Virtualmin.


Also tried rolling back theme version to 19.85 and cleared cache. Did not help.

Happening with a bunch of servers that were upgraded. :confused: hoping for a quick resolution.

Hey, guys!

This is annoying as I cannot reproduce this issue.

A first suggestion would be is to try to clear internal cache by using a link in the right side slider:

If that doesn’t help, try restarting Webmin manually (checking if pid changes).

Does it help at all?

Also, how did you install packages upgrades?

Thanks Ilia. Tried the clear cache and manual restart of webmin - didn’t help. Upgrades are run using the inbuilt interface. I have other servers that have had updates run, but not yet restarted. They are ok and still showing as; webmin version 1.990, usermin 1.834, virtualmin 6.17 pro, Theme 19.85.1.
After reboot; webmin version 1.991, usermin 1.840, virtualmin 7.0 pro, theme 19.91.2

I can confirm the same issue for my system.

CentOS 7.9
Webmin 1.991
Virtualmin 7.0 Pro upgraded from 6.17 Pro

Issue happened before update of Theme.
Issue is present for both root and normal users
Check of /etc/webmin/webmin.acl completed
Re-install of Webmin did not help.

Let me know if you need access to a box to have a look. Happy to help out.

If you SSH to your server and run:

dnf reinstall webmin

… does it solve your problem? Before running the reinstall try checking on Webmin’s PID before and after by running:

ps aux |grep miniserv

… does it change?

It seems that the issue only pops up on RHEL systems.

Also, have a look at Webmin ⇾ Webmin Actions Log – is there anything interesting can be found in for Software Package Updates module?

Hi Ilia

Same thing here, cleared Webmin cache and restarted it from cli. The issue is still here. Updated from interface.

Thanks Ilia
Nothing interesting in the actions log,

[root@vm3 ~]# ps aux |grep miniserv
root 154273 0.0 0.4 155588 75216 ? Ss May02 0:02 /usr/bin/perl /usr/libexec/webmin/ /etc/webmin/miniserv.conf
root 154825 0.0 0.1 93064 18424 ? Ss May02 0:00 /usr/bin/perl /usr/libexec/usermin/ /etc/usermin/miniserv.conf
root 187658 0.0 0.0 112812 976 pts/0 S+ 00:08 0:00 grep --color=auto miniserv
[root@vm3 ~]# dnf reinstall webmin
-bash: dnf: command not found
[root@vm3 ~]# yum reinstall webmin
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

If above article doesn’t help to resolve this issue please use

Resolving Dependencies
→ Running transaction check
—> Package webmin.noarch 0:1.991-1 will be reinstalled
→ Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

webmin noarch 1.991-1 virtualmin-universal 38 M

Transaction Summary

Reinstall 1 Package

Total download size: 38 M
Installed size: 122 M
Is this ok [y/d/N]: y
Downloading packages:
webmin-1.991-1.noarch.rpm | 38 MB 00:00:06
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : webmin-1.991-1.noarch 1/1
Stopping Webmin server in /usr/libexec/webmin
cat: /var/webmin/ No such file or directory
Verifying : webmin-1.991-1.noarch 1/1

webmin.noarch 0:1.991-1

You have new mail in /var/spool/mail/root
[root@vm3 ~]# ps aux |grep miniserv
root 154825 0.0 0.1 93064 18424 ? Ss May02 0:00 /usr/bin/perl /usr/libexec/usermin/ /etc/usermin/miniserv.conf
root 188793 0.0 0.4 255624 73276 ? Ss 00:10 0:00 /usr/bin/perl /usr/libexec/webmin/ /etc/webmin/miniserv.conf
root 188861 0.0 0.0 112812 976 pts/0 S+ 00:10 0:00 grep --color=auto miniserv
[root@vm3 ~]#

No change. Tried a server restart too. No change.

Okay! I see this issue too with Virtualmin Pro installs! We will have to wait for @Joe to wake up and fix that!

1 Like

Ok. Thanks. All our servers are Pro installations. Hopefully @Joe can resolve quickly. Again, happy to provide access to a machine if it helps to resolve.

1 Like

I have taken a deeper look and Virtualmin packages on RHEL are missing /lang directory in /usr/libexec/webmin/virtual-server. This can be manually fixed by adding /lang directory to the package from this link.

We need to wait for @Joe to roll a fixed version of the packages.

Hi there ,

Same here on
Rocky Linux 8
Webmin 1.991
Virtualmin 7.0 Pro upgraded
Authentic theme 19.91.2

Restarting server did nothing .

Thank you .

Thanks. I have confirmed with one server that manually creating the folder, copying the files into that folder. Restart webmin and clear cache - seems to fix the issue.

How do we revert to an earlier version while awaiting Joe?