Virtualmin installation stuck at "Installing Virtualmin 7 and all related packages"

I’ve created a new droplet in DigitalOcean multiple times trying to install virtualmin, tried creating a new vpc but still no luck.

The installation step I tried was:

chmod a+x
./ -b LEMP -m -v

here’s the screenshot of the installation progress:

and here’s the screenshot of the virtualmin-install.log:

any help will be appreciated

OS type and version UBUNTU 22.04
Webmin version Latest (installing)
Virtualmin version Latest (installing)
Related packages n/a

Not sure where you getting that extra commands from.
Did you read the docs?

Simple install

extra commands at

Also I don’t see any errors. Or is it just pausing at that last line?

The extra commands I added supposed to install using LEMP bundle with minimal installation setup and verbose logging enabled right? and yes, the installation is pausing at that line (Get: 62 blabla) for a long time (almost an hour), so then I cancel the installation process.

I also tried simple install following the step from Downloading and Installing:

The simple install unfortunately also didn’t work, getting the same issue (pausing at that Get: 62 blabla). That’s why I came up with the extra command trying to install with minimal build, lemp and verbose loggin to see the logs but still no luck.


I have tried installing on Ubuntu 22.04 and everything worked just fine!

What is logged to virtualmin-install.log file? Have you tried running the following before installation and seeing if it works in the first place?

apt-get update
apt-get upgrade -y

Furthermore, is this clean minimal installation of Ubuntu 22.04?

Or, is this one of the DO “Marketplace/Paperspace” droplets.

I tested with those exact commands, works fine as well on same OS.

Yes, I’ve run these command before running the virtualmin installation :

apt-get update
apt-get upgrade -y

I think this one is DO’s ubuntu minimal install image, I choose the os from the image selection below:

May I know which region you selected before creating the new instance? Mine was not working in SG Datacenter1 region

I use Vultr not DigitalOcean sorry I didn’t mention that.

I see. I also have Linode instance and everything went well on it, virtualmin installed and running smoothly with other provider. Seems like only DO droplets having the issue with installing virtualmin.

1 Like

If you tried executing before Virtualmin installation script:

apt-get --quiet --assume-yes purge ufw

… do you experience any issues running this command?

Trying to recreate this … SG - Datacenter 1 is not available to me - what country is SG?

it’s Singapore with Datacenter 1 -

no issue while purging ufw without --quiet command, seems works fine

sudo apt-get purge ufw

Could you share virtualmin-install.log file? I’d like to see what’s happening wrong exactly. It isn’t clear right now.

By the way, I was trying to create a droplet in DigitalOcean, but they banned my account for no particular reason, so I cannot do much of anything right now. If you can PM me credentials to your DigitalOcean instance, that would also work.

Yes, absolutely, Linode has been my personal preference.

SGP not SG for clarity

ah yes you’re right, I mean SGP (Singapore). Sorry for that :v:

1 Like

Sure, here’s the virtualmin-install.log file -
virtualmin-install.log (15.2 KB)

There is nothing evidently wrong in the log. What if you manually try to install the packages that are denoted in the log?

Yes, the log look like the installation process working fine but what happens is that it never completed. Being stuck in this process Installing Virtualmin 7 and all related packages for more than 2 hours now. And I don’t think manually installing the package is a best solution to this problem. I’ll switch to another provider for now. Thanks.