virtualmin installation failure


I’ve tried several times to install Virtualmin on my fresh VPS (openvz, ubuntu 14.04.01 LTS)

Install script always ends with fatal errors

Log attached

edit: wont let me attach file !


Would it be possible to provide us with a link to your installation log somewhere else?

However, it should allow you to attach a file, though you may need to give it a .txt extension.



tried several times to attach file (78KB .txt file) but keep getting “Oops there was a problem” message so here is a link to it:


Other clues - I can log in to Webmin, but MySQL not running and has message:

“MySQL is not running on your system - database list could not be retrieved.”

If I try to start it I get:

"Failed to start database :

start: Job failed to start"


Ah, it looks like it almost finished, but ran into trouble installing one of the packages (Webmin and Virtualmin won’t be setup properly at the moment, I wouldn’t recommend trying to use them until the installer completes properly).

What output do you receive if you run this command as root from the command line:

apt-get install postfix postfix-pcre ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail procmail-wrapper libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-fresh clam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php5 php5-cgi libapache2-mod-php5 php5-mysql

Hi Eric,

I get:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘ruby’ instead of ‘irb’
Note, selecting ‘ruby’ instead of ‘rdoc’
Note, selecting ‘dovecot-core’ instead of ‘dovecot-common’
Note, selecting ‘proftpd-basic’ instead of ‘proftpd’
E: Unable to locate package clamav-fresh
E: Unable to locate package clam

Okay, try running this command and see what this outputs:

dpkg --configure -a

Setting up mysql-server-5.5 (5.5.40-0ubuntu0.14.04.1) …
debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/ line 76.)
debconf: falling back to frontend: Readline
Configuring mysql-server-5.5

While not mandatory, it is highly recommended that you set a password for the
MySQL administrative “root” user.

If this field is left blank, the password will not be changed.

New password for the MySQL “root” user:

Repeat password for the MySQL “root” user:

/var/lib/dpkg/info/mysql-server-5.5.postinst: line 146: logger: command not found
ATTENTION: An error has occured. More info is in the syslog!
/var/lib/dpkg/info/mysql-server-5.5.postinst: line 236: logger: command not found
dpkg: error processing package mysql-server-5.5 (–configure):
subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

Aha, there we go… apparently the “bsdutils” package isn’t installed.

Try installing that with this command:

apt-get install bsdutils

Once you do that, run this command again:

dpkg --configure -a

If that runs without error, try running the installer again, and see if that works properly now.


Hi Eric,

Brilliant - that seems to have solved the problem.

Thanks for all your help.

For my information, why would bsdutils not have been installed. Is it something missing from the Ubuntu OS image that my VPS provider had made available? I’ve not had this problem on same OS/version but different VPS provider.

Cheers and happy holidays



Normally, bsdutils is installed on a fresh version of Ubuntu. It is listed on Ubuntu’s site as “essential”, meaning it’s considered to be required for a functional Ubuntu installation:

However, you aren’t the first one who mentioned that was missing from their VPS image. What I was planning to do was to add “bsdutils” to the Virtualmin installer, and if for some reason it’s not included in a VPS image in the future, no problem, that’ll get installed along with Virtualmin.

In fact, I’ve just done that… the next installer version to go out will include bsdutils (it may be a bit before that gets pushed out, so if you run into that issue in the meantime, you may just need to manually install that package).