Virtualmin install on Centos 8

do you have some recommandation how to install Virtualmin on fresh Centos 8 install now in April? I´ve tried to install it twice and got errors with GEO-IP and epel-release after that I´ve rather reinstalled OS. Now with already installed perl dependencies, before I will start to fight can you please navigate me in order to avoid those errors and install it on this new clean Centos 8 installation? I am very new to Linux so please provide me also with commands, as I need to only install it once and then manage Virtualmin/Webmin. Thank You


It’s actually a bug in CentOS 8 itself.

Check here for details on how to work-around Awstats error, and here is how to work around few other small issues.

All of this will be fixed in the near future by @Joe.

Thanks Ilia for your respond, I have already installed it, I´ve followed some tutorial telling that it is better to start with Webmin installation, and then to continue to install Virtualmin module, and it worked, no issues with awstat etc. Where I got a problem is that when I´ve created a Virtual server, Apache stopped working, I got this message: Job for httpd.service failed because the control proces exited with error code. See systemctl status httpd.service and journalctl -xe for details, I can start it only if I delete that newly created Virtual Server.

That tutorial is wrong. You’ve got an incomplete installation that won’t match whatever everybody else has (which means we can’t help you). But, if you’re happy with it, I guess carry on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.