Virtualmin Install on AlmaLinux 8.6 Has Been a Fiasco

OS type and version AlmaLinux 8.6
Webmin version 1.994
Virtualmin version 7.1
Related packages SUGGESTED

I installed Virtualmin on AlmaLinux 8.6 minimal using the beta installer linked on another thread, and encountered the following errors:

ClamAV couldn’t connect to socket. Skipped.
MariaDM couldn’t be started. sh: /etc/rc.d/init.d/mysqld: No such file or directory
Apache won’t start.
BIND won’t start.
Dovecot won’t start.
Upgrade to Pro failed (404 on the server on Virtualmin’s end after entering the serial and key).

Other than that, everything is fine. :roll_eyes:

I’m hoping this can be fixed without a reinstall because the client-side reinstall on my host’s site didn’t work right (apparently the image is corrupted), so one of their techs did a manual install of AlmaLinux minimal for me in the DC.

On the bright side, there’s no rush on any of this.


This is known issue (much discussed), at least the MySQL thing (not sure about the others, but OS misdetection is very bad, so it can break all kinds of things). New Webmin release coming tonight or in the morning fixes it.

1 Like

Thanks, Joe.

Actually, Apache is working, and I fixed BIND and Dovecot. But Apache shows up as stopped on the dashboard. I have no idea why.


It’s not just the dashboard that believes Apache isn’t running.

When I get an SSL from Let’s Encrypt, and the script wants to configure Apache to use it, it throws an error that it’s not running. So basically, Webmin / Virtualmin don’t know that Apache is running, even though it is running and can serve HTML pages (haven’t tested PHP yet).

The dashboard does show that PHP-FPM is running. I haven’t tested it yet.


Okay, PHP pages work.

I suspect this is just another symptom of misdetection of OS. Webmin doesn’t know where anything is if it detects the OS as something entirely different.

Okay, so the update that should be awaiting me when I pour my morning coffee may fix it.

Maybe next time I’ll go with Rocky.

Thanks, Joe.

Running dnf update: is 404. What should the correct url be?


Okay, this seems to be a two-step process to upgrade to Pro.

Step 1: Edit the virtualmin-noarch repo to

and start the upgrade. It will make it part way through, and then fail because it will rewrite the repo back the same way it was earlier. So edit it again, this time to

And re-run the upgrade. It should work the second time.

It also clears up the dnf error.


Updates won’t fix misdetection of OS. It’ll take a reinstall.

That sounds like a bug in the virtualmin release package. I’ll have to sort that out. I tested a pro install, I thought, but maybe I made repo changes in the intervening time. I’ll try to sort it out shortly.

I’m probably wasting my time, but I’m going to try a few less-drastic fixes. This is not yet a production server, and it’s been a while since I’ve done anything like this; so if nothing else, it will exercise my old brain. I’ll keep notes and maybe post a thread if if works.


This was 100% fixed. I have build locally Webmin 1.995 and it works as designed. It will require either clean reinstall to have it fixed or removing mentioned Webmin modules configs before running Webmin 1.995 upgrade (when released).

You are right - this needs fixing! Will do!

I know it has been mentioned elsewhere but just wanted to chime in that I am running Virtualmin 7.1 Pro (not beta) on Alma Linux 8.6 in production and without any issues. I of course used the route of installing Centos 8 minimal > Virtualmin > Alma linux conversion. Only issue I had since last year when I did this was the most recent virtualmin update caused webmin to stop (post successful update). Simply starting the process again solved that.

I considered doing it that way, but decided to give Rocky a try. I’m stomping some bugs (but many fewer) on the configuration as we speak.


Maybe this is old school, but the install script could ask the user to confirm the OS detected by the script.

No. We don’t need to ask more questions. It’s a simple (silly) bug. Detecting OS is a solved problem, we just screwed up.

1 Like

What’s funny is that it worked up until Webmin 1.991. Trying to get more precise is when it broke. :wink:

Maybe a coincidence? Possibly something changed with AlmaLinux. It’s the only OS that seems to be having a problem with it, no?

No, we definitely broke it. We understand the problem. It’s fixed in Webmin 1.995 (or whatever the next version is).