Virtualmin has gone completely funky.

Howdy folks,

I’m a fairly new Virtualmin user. I’m also fairly new to dedicated/virtual hosting, I’m trying my best here so bear with me… :slight_smile: - but things have gone completely bizarre with my installation of Virtualmin…

I’m running Ubuntu 10.04.1 and had Virtualmin setup and running just fine on a MediaTemple (ve) server. I was just beginning to set up and configure one or two basic sites to get to grips with things.

Whilst setting up ProFTPd, I realised FTP access hadn’t been working previously because ProFTPd hadn’t been starting when the server was booted up. So via Webmin (I think…) I enabled ProFTPd server to begin on bootup. To check it was all working, I restarted the server. This is where things went funny.

Take a look at this screenshot here:


As you can see, Virtualmin looks totally messed up. No images are loading and there’s no stylesheets or anything being applied.

I fathomed this was a one-off and rebooted the server again. Same problem.

Here’s where things get even stranger: when you click anything from this weird-looking display, that single click seems to disable everything. Google Chrome reports “This web page is not available.” and says it might have moved or be temporarily unavailable etc.

From this point on, it’s impossible to access any Virtualmin page at all until the server is rebooted. Once rebooted, you get the funky yellow/unstyled screen, and the process repeats: click anything, it goes down.

I fathomed, firstly, that Virtualmin was in fact down all along and this was just Chrome loading up a cached copy or something. So I tried in Safari - which I’ve never visited VM in before, so it can’t be cached - same problem…

Any ideas?



My best suggestion at the moment would be looking at the page sourcecode of the “weird looking page” and see what URLs the pictures and stylesheet have. That might give a hint as to what’s wrong. Was the hostname changed or something?

Also see that large yellow box there which says that Vmin apparently has some incorrect server OS information stored. Try clicking the button to have it re-check the OS.

Hi Locutus,

Thanks for your suggestions.

In regards to clicking the box - I can’t :frowning: Clicking anything causes the entire Virtualmin installation to become unavailable until the next restart…

However, I looked at the source code - it appears the images just point to where I’d expect - e.g. /images/down.gif for example.

However when I try and access these files - I get told they’re unavailable, same error as when accessing another page. Perhaps related?

Thanks for your help so far!

Really sounds like something got messed up pretty good with Vmin there. Maybe it’d be best to reinstall it. While you don’t have any fancy sites configured, that should be no biggie, and might be faster than trying to solve this weird problem.

You can try uninstalling it by calling the installation script with e.g.

/bin/sh -u

That should remove all Vmin packages while keeping configuration intact. Then do


to reinstall it. See if that helps. :slight_smile: And then, make sure to make good notes of any configuration steps you make. :slight_smile:

If it doesn’t help, and Webmin itself got messed up, you may have to remove its packages manually with Aptitude. Same goes for Usermin. If even that does not help (though I suppose it should), have your hoster reinstall the server and start afresh. :slight_smile:

Try a different theme before reinstalling anything.
Redownload the virtualmin framed theme, re-activate it.
See if that helps

theme can be downloaded from

If you are on a low ram VPS, per haps the installation of virtualmin went banana’s.

I doubt he’ll be able to re-activate the theme if he can’t even click on the “Re-check configuration” button. :slight_smile:

Though reinstalling it via Aptitude might help, in case any of the theme’s files are damaged.

Also check the logs in /var/log/syslog, /var/webmin and /var/log/virtualmin for errors.

indeed, however it can be done over the command line
uninstall and reinstall the theme downloadable from here

perhaps it helps