Virtualmin frequent failure


I’m experiencing Virtualmin often shutting down. If I go to log into Virtualmin for a long time, it’s unreachable - like offline. So I can’t login. I have to restart the entire server and than I can see login page.

Is this some security feature, or something is bad?

Thanks for help.


What you’re describing doesn’t sound normal…

Are you by chance on a VPS?

And how much memory is on your system – you can determine that by running “free -m”.


and probably you don’t have to reboot the server. you could try ssh and /etc/webmin/start or so.

Hallo, thanks for reply.

Yes, I’m running on the VPS, “free -m” returns me 4GB available, 1,2GB used.

Maybe I did wrong, when I set virtual on the same domain, like the FQDN. So I was accessing Virtualmin via https://FQDN:port and I also had virtual server on http://FQDN.

Next thing what I did and might be unusual: I set verified certificate by CA instead of the default on https://FQDN:port

I noticed this problem on 3.88 too, but not from the beginning.

Do you have a /proc/user_beancounters file? If so, can you paste in it’s contents?

None of the things you’re describing above should cause Webmin/Virtualmin to die, so it sounds like something else may be going on.

Also, in addition to the /proc/user_beancounters file, you may want to take a peek in the /var/webmin/miniserv.error file to see if anything unusual shows up there.


I attached the user_beancounters file. In the miniserv.error I dont see any errors between last login (which indicates Bad request) and webmin start (indicated by started i guess). Cut of this case:

[18/Jan/2012:15:09:52 +0100] [82.100.x.x] Bad Request : This web server is running in SSL mode. Try the URL <a href=' [22/Jan/2012:14:30:40 +0100] started [22/Jan/2012:14:30:40 +0100] PAM authentication enabled [22/Jan/2012:14:30:42 +0100] [82.100.x.x] Bad Request : This web server is running in SSL mode. Try the URL <a href='

Okay, so here’s the problem – regardless of how much RAM that “free -m” is showing available at the moment, your VPS is running into resource limits.

The “kmemsize” parameter had nearly 2000 failures, and the privvmpages and oomguarpages parameters had 12 and 16 failures.

That means that processes on your system are hitting resource limits of some kind and failing.

So the problem is likely that Virtualmin is being killed off due to those resource limits.

Other processes are being killed too, but it’s less noticable if, say, PHP is killed off, as it might work well if the user just hits “Reload” in their browser.

You may need to work with your provider on what exactly your limits are, and the reason you’re running into those limits.


kmemsize restricts basically the number of processes. That means you have to many processes running on your server - or your kmemsize is too low (“only 100MB” right, should be probably 1000mb or so).

If your host can not change the value, then you need to do some apache and/or mysql tuning :slight_smile: Or maybe try nginx (just introduced in Virtulmin)

Well thanks you all.

My provider temporarily doubled the limit, but he was suprised and he noted this is strange. I have to analyze processes and find whats wrong.

Best regards, Nikos

how many processes do you have in peak times?

I have a 512mb VPS and the provider set kmemsize limit to 2048MB …

Re: helpmin. I’m not too familiar with servers, I’m webdeveloper and Virtualmin is quite easy tool how to set development and production enviroment. So how to find processes in peak times? In the Virtualmin @ System information I see 70 processes.