Virtualmin failed 550 5.1.1

OS type and version centos-8
Virtualmin version 7.1

So I am not sure how to get started.

I have a domain/virtual server say which uses Google Workspace for sending and receiving emails.

Now i added another server which does not use google workspace and uses virtualmin inbuild capabilities to send and receive emails.

Now if i try to send emails from to it will fail giving error virtualmin failed 550 5.1.1

I can send emails from a@secondary to any other email like but not to

Also digging deeper, somehow i had email enabled for primary virtualserver and it kept in delivering emails to usermin account vs my google workspace.

I disabled it and now i am getting this error.

Looking at mail log, this is the error

Sep 25 05:07:34 HOST postfix/smtpd[14041]: NOQUEUE: reject: RCPT from localhost[]: 550 5.1.1 Recipient address rejected: User unknown in local recipient table; proto=SMTP helo=

Please note, i am using fake domains here and host is my virtual server.

Can somehow help me with this.

Please do let me know if any more details are required.


Do you have email enabled for in Virtualmin by any chance? If so, the server will attempt to hijack the request.

*** Profesional, Affordable, Trusted Technical Support ***

I had it but it’s now disabled but still the error.

I forgot to mention that my server/host name is setup in a following format.

And so I actually have 2 server instances and also

I read few articles that this can possibly create a conflict and it’s better to change the host name so I am in works on getting the host name changed to something else (another domain)


Yes, you should never use the “naked” domain for a server hostname.

Hostnames should always have a sub-domain in front of them: “

If you’d like me to help you diagnose the actual cause of your problem, I will be available tomorrow as I’ll be out today. Drop me a line.

I work with clients who send out millions of messages per day in a multi-server cluster environment I developed for them. I know email quite well.

disable local email for , fix MX entries in nameserver to only point to evilcorp workspace (+SPF/DMARC accordingly to evilcorp) and remove any other mail references pointing to your own server…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.