Virtualmin error: There are no DNS zones defined for this name server

Hi all,

A few days ago I installed a web server on CentOS 8 with the Virtualmin installation script. I had some small problems that were solved in this forum thread:: Virtualmin support for CentOS 8

Now I run into issues with DNS Bind server not showing domain in module: There are no DNS zones defined for this name server

Due to this, the server does not solve my DNS and I have problems getting the Let’s Encrypt certificate.

Any ideas? Thank you


Are there actually BIND DNS records in its config, and Webmin just can’t find them right (configurable in module Configuration/System configuration) or there are just no records at all?

If I have records in /etc/named.conf and /var/named/

I don’t understand the configuration path you say “Configuration/System”, where Webmin or Virtualmin?

do you have any domains created on the server ? (what does the DNS records hold?)

If I have a domain that I have for testing I have moved it to a new server where Virtualmin is now.

Either way I uninstalled and reinstalled BIND and now if Existing DNS Zones appear

But there is a part of the code that is less illuminated than the other part.

If I comment the line /* */ with two slash //, if the rest of the code appears illuminated

The first one is the one generated by Webmin, but my doubt is if the DNS are spread when that area is “off”

On another server that I have with Webmin/Virtualmin that zone is illuminated and the line / does not exist and has worked well for years.

Should I comment that line on the new server with two slash //?

sorry, I can’t be any help.
I have no idea what that means :o(
I just add a domain and the DNS records get added and I can check the named file, thats the level of my knowledge.

Usually its a comment as it currently is. Meaning its inteded that it doesnt run the code inside the comment zone. I am pretty sure if you take a look to the end you will find additional comment markers.
And my guess is, that you should check the URL before you enable it.

It seems to me that in the installation script of Virtualmin there is an error in the way of writing the comments, it uses the HTML nomenclature /* comment here */, while BIND uses two bars to the right // for the comments, so it should be corrected in the corresponding code. I have left the two bars // and it seems that if the DNS are spread

Nothing happens, thanks for your interest

The install script didn’t do that, for sure. I don’t think Webmin’s BIND module would do it, either, but I’ll see if I can reproduce it.

Nope. Can’t reproduce it, and I’ve never seen his behavior before. I’ll need to see the steps you used to make this happen to do anything else with it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.