Virtualmin - enable postgresql for new virtual server

Hi all

I have an issue with postfix and virtualmin on a production server. Most of the sites I host for clients run on mysql databases, so I have never noticed that the postgres option is not visible in the Enabled Features section of the Create Virtual Server page.

The postgres db server is present in Webmin > Servers and I am able to create dbs via this method but that doesn’t allow me to associate them with a virtual server.

How do I go about enabling this feature and allowing my users to manage the postgres databases?



In System Settings -> Features and Plugins, check that “PostgreSQL database” is selected. That needs to be enabled before the option will show up for Virtual Server owners.


oh wow

I knew it would be something simple that I had overlooked but that’s just plain stupidity on my part!

Thanks for the solution Eric…