Virtualmin DNS question

Can anyone please help me troubleshoot DNS issue?

I’m having difficulty with DNS propagation on my server, which is managed by GoDaddy. I’ve added hostname servers ns1 and ns2, pointing to the IP address of the server where Virtualmin is installed, but the DNS changes take up to 48 hours to take effect, making it difficult to troubleshoot any issues that may arise. Sometimes the DNS works as expected, but other times it seems to disappear without warning. I’m not sure where to look for possible causes or solutions to this problem.

Below is the DNS Record for the virtual server. Its just one server at the moment. I am planning to add more in the future.

Services that are running on Virtual-min are below.

Not sure what am I missing.

What I really would like to do is have ns1.mydomain.com & ns2.mydomain.com. So If I add a new Virtual Server, I should be able to point my other domain to nameserver ns1.mydomain.com & ns2.mydomain.com

I also need sub domains too on the Virtualmin. So would that be sub server? Also do I need to update any records for the sub domain?

Thanks in Advance.

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Virtualmin version 7.3-1
Related packages SUGGESTED
AWS EC2 Instance

Propagation usually takes minutes these days, at least at my registrars (Namesilo for most TLD’s and 101Domain for .aero).

My hunch is that you’re experiencing caching somewhere. It could be on your computer, your router, or (least likely) on your server’s upstream resolvers.

Also, your server should be listed as a nameserver for itself, as well. At least that’s how I’ve been doing it, with no issues.

Try clearing your device DNS cache (and your router’s if applicable) and checking again.

Richard

Thanks for the response, I just checked my office computer using remote desktop, which is a different network, router and ISP. I couldn’t reach the page using port 10000

Upon checking whatmydns I see some propagation below for the NS but for A record nothing yet.

I am in Australia. Should I wait until my ns1 & ns2 is resolved in Australia?

More likley you PC or router is the slow one, it use DNS cache and follow the TTL records.
Try clearing cache with ipconfig /flushdns and rebooting router. Posted 1 hour ago, i guess its working now? Also I use this to update opendns cache, sometimes quickens things, https://cachecheck.opendns.com/

1 Like

It wouldn’t hurt, but as @stefan1959 said, the caching is probably close to you, either in your PC or router.

Typically, the computer checks its own cache first, and then requests it from the router if it doesn’t find the hostname in cache. The router then checks its own cache before requesting the IP from upstream DNS. Depending on the TTL’s, you could be the last person in the world whose computer fetches the new IP.

Richard

Thanks for the response.

No sorry it’s still not working. I am wondering if I have done the correct way.

I have used Office PC which is on different Router and ISP. I got the same result back.

So I added Hostname Server ns1 & ns2. Then I updated NameServer to ns1 & ns2 on Godaddy.

Then I added Virtual Server in Virtualmin. Is this correct way to do it?

Also if i have another domain e.g example.com

So in the domain account I will add ns1 & ns2 hostname server and point to the IP of the server. Then add NS ns1.example.com & ns2.example.com? Is this correct? I mean i can try another domain instead of waiting for this?

GoDaddy will take seconds, not hours or days. You’re either doing something bad wrong or have a big issue on your configuration.

GoDaddy is pretty strict about what they’ll allow as a nameserver. Typically, you have to already have a domain set up before they’ll accept it. They also will not accept direct IP input as a nameserver. That’s probably why it’s not working.

You’d probably have far better luck using Cloudflare. Set up a Cloudflare account using your domain. It will give you the name servers to enter at GoDaddy.

Once you do that, you enter the records into your Cloudflare account and point them to your IP and it will work instantly.

1 Like

Cloudflare can also be complicated for folks who don’t understand how any of this works.

Getting a handle on how DNS works is probably the single most useful day or two of reading anybody working on the web can do. Really, so much relies on DNS, and so much that goes wrong comes down to DNS misconfiguration or misunderstandings that it really doesn’t make sense to not get comfortable with it.

1 Like

use https://mxtoolbox.com/ it has alot of testing tools not just mx