Virtualmin DNS Problems - was port 53!!

Im sure some random comment somewhere could help so I’m sorry if you know where that is but I need some help and have read a ton trying to double check my work here… I am new to VPS and didnt know I needed to know so much about DNS lol. Ive been offering managed hosting for like 8 years but new to VPS so anyways…

I have my main domain - (yes that is the correct extension). I setup my vps with no subdomain as the hostname. Seems like some people suggest doing a subdomain too but for me that would work best. From what I can see this shouldn’t cause any problems overall.

I setup custom dns at namecheap with ns1 and ns2 pointing to my 1 IP. I have the NS of that MAIN domain pointing to cloudns premium name servers where I have all records and subdomains routing correctly from what I can see (including A records for ns1 and ns2). IntoDNS confirms that main domain should be setup perfectly.

SO here’s the rub. I setup a new customer (lets call them with my custom name servers, and Godaddy accepted them no problem. BUT even though my ip, and ns1 and ns2 all resolve to my VPS correctly, only shows cached in turkey!! And into dns says my IP doesnt resolve at all?!?! Its been about 2 days. What in the world?!

FYI - I do have necessary A and NS zone records setup with’s zone file within their VPS. Also I have another customer correctly setup on a separate account on that VPS but not by using ns1 and ns2 as NS.

Please help!


Good luck DNS can be a nightmare unless your intodns.

2 days is a length of time for propagation but it can happen with some services offered by people.

This new customer … owns their domain I guess or are you just letting out rooms so to speak on your main domain.

If they have their own TLD you should look at the DNS setup at their registrar ( of which you will never have control to direct the domain to your IP numerical address ) I would have thought.

Maybe I have not understood something here as usual but maybe your complicating DNS beyond what it needs to be.

A reply always helps in some way, wish I had a magic wand.


In a terminal from anywhere… run “dig domain-in-question”. Will tell you if your NS is responding with right ip. Then do a dig on public nameservers like or “dig @ domain-in-question”. That will tell you if public servers are getting the info. If local NS shows correct but public does not, then firewall or bind setting is not allow propagation to public. if you get no A record for either, try running same commands from the VPS itself. dig @ domain-in-question.

All three commands above should show an ANSWER SECTION ‘A record’ with the domain and IP without a semi colon in front of it.

hi spds,

I noticed that you are new to this - as you said, did you read all docs regards dns? also - if you new of course you are, did you think to ask for pro help of virtualmin guys about this issue… seems to me that you asking here helping to solve the issue for your customer - as you mentioned in your question… means business thing… good luck man.

Thank you for the recommendation!

Both dig and dig say
“; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached”

Same results if i do dig on my working customer’s url!

I control their whole domain. I will be hosting the site and email so I need to be the NS. Like I mentioned godaddy accepted my ns1 and ns2 NS so thats all set.

Thanks for the reply, no the problem is mine not my customers.

I need to be the NS so I can host all of their services, site, email, etc.

Also, like I said I have another customer up and running no problem. The only difference is that I put their NS from goddaddy to cloudns then to me, vs straight to me like I am trying to do now.

That’s why I am confused, essentially I am doing the same thing in both cases just the zone files are in 2 different places. But both customers are setup in their own account in virtualmin on my VPS. This should be easy the second/third time around lol.

Thank you for the recommendation Scott!

Both dig and dig say “; (1 server found) ;; global options: +cmd ;; connection timed out; no servers could be reached”

Same results if i do dig on my working customer’s url!

I dont know if this helps but heres 2 customers. First is working great, second is not (DNS wont resolve to me)

Customer #1 - Godaddy NS pointed to cloudns | CloudNS is where all zone files are set to point to my VPS IP | VPS routes domain request to correct account in and out. ALL IS WORKING HERE

Customer #2 - Godaddy NS pointed to and (yes I have the custom ns registered at my domain’s parent NS and matching A and NS records on the vps side too) | Customer’s virtualmin account is where all zone files are set to point to my VPS IP or applicable places. mx, ptr, spf, a, etc | VPS SHOULD route incoming requests to correct account in and out. BUT ISN’T.

DNS lookups for that domain when tested all just say no response or it times out. I dont think it would hurt to share the problem domain in question, its

Can you pm me the problem domain and images of the DNS records setup for the problem and working domain.

I think you can pm me here?

Or email at david at

I firmly believe that all can be solved if looked into enough :slight_smile:

OH MY GOSH! I really hope this helps someone else! It was so [well, kinda] simple!!!

I kept just asking myself why inbound requests didn’t seem to be getting through (using my ns1 and ns2) or going to the right place (which would make the dns not resolve, as found on whatsmydns and then it clicked! I googled what port dns works on and its port 53 WHICH MY VPS COMPANY WAS BLOCKING!! It was confusing cuz my main vps domain was working great, but any sites using my personal nameservers ns1 and ns2 werent connecting. BIND works on port 53 so literally minutes after opening that port everything connected!!