Virtualmin Debian 10 mod_php missing

Hello all,

PHP Script execution mode - mod_php missing on Debian 10

My website script requires to use mod_php. now I’m lost I don’t know what to do. in my previous server, I had mod_php and I had no issue.

Thank you

We don’t recommend installing mod_php it’s not only insecure but may cause other issues with current release. I cannot imaging a case, where an app would not be able to run using FCGId or FPM and required mod_php.

However, it’s up to you and you can install mod_php with the following command:

apt-get install libapache2-mod-php
1 Like

Thank you @Ilia for your advice. Script/app can be run using FCGId or FPM however the developer guide says that I need to run it under mod_php

It’s time that I double-check with the developer. if needed I can use the command to install mod_php


It’s a bad advice, really.

Can I have a link to an app and this recommendation?

@Ilia Script uses FFMPEG to convert videos and edit videos

It might be related to large uploads, I guess, as those may fail on (F)CGI.

Still, try using FPM and see if it fail.

We would be appreciate for further feedback.

@Ilia according to the Documentation given by the developer yes, I believe mod_php recommended for huge file conversion and uploads downloads, etc… However, I’ve asked the developer for a great explanation will keep you posted

Oh and BTW apt-get install libapache2-mod-php
did the trick and now i can select the execution mode but at the moment i’m gonna pause it until i hear from the dev.

@anthonyinit2012 you can mark post at this link Virtualmin Debian 10 mod_php missing as solution :wink:

1 Like

The explanation would be interesting to read, indeed! It’s fancy.

If you have to deal with super large uploads and keep it secure you can easily handle it using apache2-mpm-itk. However, it’s not yet officially supported in Virtualmin.

I would propose trying FPM and see if it works.

1 Like

Got a reply from the developer This has to do something with progress bar, not a major issue I guess.

you can use FastCGI…the only issue you might experience is this, but there are ways to address it:

This could be an indication of a networking problem on your server (relating to the configuration of network card software on your server). Contact your hosting provider to see if there is anything that they can do on their end.

This might be a cURL, PHP cURL extension, or PHP output buffering issue. Verify that cURL, PHP, and the PHP cURL extension are installed and configured correctly. Check the output buffering directives in your server’s php.ini.

Your server might have a very fast download speed. If the speed is fast enough, consistently, it is possible that the download progress bar is absent because it never has a chance to clear the output buffer before the download completes.

If you are running cPanel, Plesk, Virtualmin, or a similar hosting control panel software, check to see if any of the settings in your control panel are conflicting with the download progress bar. In particular, via your control panel or otherwise, try configuring PHP to run as an Apache module instead of via a CGI wrapper (or vice versa?). Often, adjusting this setting will cause the download progress bar to start working.

If you are using Plesk, try disabling Nginx as an Apache/HTTP accelerator and/or reverse proxy server. Plesk appears to install Nginx as a dependency package and has configured it (with Apache and PHP) in such a way that it may interfere with the progress bar.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.