Virtualmin config error when adding newtop level Domains it knocks all other domains error 503


Centos 8.4.2105
|**Webmin version: 1.981
|Virtualmin version:|6.17
php 7.4.25

I didnt not make any changes to any server config files. It started today randomly, I can not add new virual servers to the system as it kills the PHP-FPM and makes it unload able. I believe this is a conflicting config error but I can not locate it anywhere. the error in the system PHP-FPM states that the required system resources are being used by another Pool.

Their is only one version of PHP running on this sytem, it has been running perfectly for over 2 months until today.

I am a completely new to this operating system and virtualmin.

the only way to restore the system is to delete the newly created server. then everything functions again as normal

Hello @Jefowles and welcome to the community.

It appears that the act of adding a virtual server on your system creates a config file in the PHP-FPM pool that is causing problems. Try this, as a quick and dirty workaround, while we await better suggestions from the community:

  1. create a virtual server as usual
  2. in the new virtual server that you have created, change PHP script execution mode to FGCId under Virtualmin → Server Configuration → PHP Options
  3. hit Save
  4. change PHP script execution mode to FPM under Virtualmin → Server Configuration → PHP Options
  5. hit Save

Let us know if this works - if my prognosis is correct, your system will now work normally. The config file issue which was causing PHP-FPM to be killed (or not start at all) would have been resolved and all virtual servers, including the new one, will be able to use PHP-FPM.

i tried something similar to that earlier today just by disabling and reenabling fpm, I dont have mod_fcgid installed on this centos 8 machine. However I have been digging and I discovered that when virtualmin creates a new server it reuses existing ports causing conflicts. I can manually change them, restart and the older servers resume full function, But… no matter what I do no php file will be severed by the new virtual server. just .html and such. php extensions return a simple “file not found” no matter what I try and I can not find any errors in the logs as why… i am beginning to get a headache… something in the Virtualmin configs go seriously corrupted somehow. Every new server has a built in defect.

I guess my next question is… can I backup the databases and files of the sites cleanly? or is this error going to be sewn in to the backup files… I want to dump the machine and do a clean reinstall. Then reinstall the databases and site files from the backups. I only host 15 virtual servers on this box. take about a day to redo the box config and reinstall virtualmin. This instability has rendered everything static and unusable. cant touch any settings with out it crashing something…

Virtualmin Backup offers granular backup and restore options, so you will be able to restore just the web content and database from a full backup and the issue with the config file in the PHP-FPM pool will not get carried forward to the new server from the old server.

I don’t know if doing a clean install will solve your problem. If I were you, I would spend my time and energy on the server which has the issue, understand it and fix it rather than doing a clean install and hoping everything will magically work on the new server when it wasn’t on the old one.

the server ran flawless for months, right up until a week ago when a winter storm hit us northerners… it got spiked when the data center lost power for 14 hours, right in the middle of the nightly maintenance cycle, updating and backing up.

Maybe something in templates or other default Virtualmin to create , used changed back to older or one that is not as should be.

If possible check those default at creation and templates and settings used.

There was such problem longer time ago with Virtualmin, i don’t know it was then related to a config / settings or template… or even account plans…!!!

yaaa. I have been crawling through everything line by line, their has to be a reason it is not indexing the sockets each time it creates a new server. I dont understand the processes it uses to determine if it has used a socket before. I think virtualmin got toasted, but apache just keeps serving up what was already their. So i didn’t really notice it until the order for a new set of sites came in today.

IN templates deafult or thhose you use: (virtualmin )System settngs >server templates ( there under php options)

Default PHP execution mode FPM ?

Also the right PHP version?

yes, it is the only choice. FPM or disabled is all i get on this centos 8 machine. only PHP 7.4.25 is installed.

Look in those config settings i mentioned above

There are the default for pools and so. ( socket and more whatever)

I will thanks… Let you know what I find… Should I switch it to socket instead of TCP port? would that stop the new servers from trying to share the ports?

Look in directives for the servers runnig for websites ssl and no ssl

there you seee what you used to use before also you can check there for conflicting after creating sometime port nr same / double , or a id not right (double) where problem i have seen in past

under that virtaulservers / services / configure (ssl) website

Also ofcourse the plan / server should be if using ssl at creation set to also ssl apache checked

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.