Virtualmin Command Line Interface (CLI) on Joyent

I was delighted to see there is a cli to virtualmin:

But when I tried it on my Joyent account, I ran into some problems, see this post:


– The virtualmin binary is there: /usr/local/sbin/virtualmin

– It works for help requests like: virtualmin help list-domains

– But it doesn’t work for: virtualmin list-domains

So mainly I’m wondering should it work on Joyent, and if so, what am I doing wrong!

Well, I suspect it should work. I’d love to hear if other Joyent folks are having trouble with that or not.

However, I think my suggestion would be to file a bug report – we’ll get Jamie’s take on the matter :slight_smile:

Be sure to include the info from your forum post in the bug report – including the error message you receive and such.



I just found out the answer: Joyent turns off the VM CLI for the shared accounts. Their claim is that it would require root access for the CLI to work. See their responses at

But this sounds fishy to me: I can use the VM web interface without being root, right?

This might be solved between Joyent and Virtualmin … it would be good for VM shared users to have the facility.