Virtualmin : Changing User Quota

I am unable to find where to change the User Quota.

The reason I ask is because the main user for one of the Virtual Serves is unable to Upload (ftp) files now because the Quota has been reached.

I’m wanting to set it to unlimited but I cannot find where to do so, I’ve looked every where but no luck.
Can anyone help me out?


Does no one know how to change the User Quota for a Virtual Server?

Does anyone have any ideas what I can do to change the User Quota?


Hey Adam,

Sorry for the slow reply.

Just edit the Virtual Server. The option you need is labeled "Total server quota".

If you’re using Virtualmin Professional you’ll find it in the left menu–select the domain in the dropdown, and then click the “Edit Virtual Server” link. In Virtualmin GPL, just click on the name of the domain in the domains list. The option is about midway down the edit page.

Oops…you also want to change the “Server administrator’s quota”. Just below the “Total server quota”. (“Total” is a group quota that applies to all users within the domain, while “Server administrator’s” applies to the domain owner account specifically.)

Hey Joe,

How come I don’t see any thing like that in Virtualmin 3.29? If go to edit vitual server, and under save virtual server there used to be a list of other options. They are gone now.

I can’t edit my servers disk quota either!!

Hey Howard,

The options that used to be under Save have been moved into other pages, or move up on the page–things were way too complicated on that page (still are), so we’ve simplified it some.

Search for "Total server quota". It should be midway down the page.

I am going to look like a total help desk call here, but I have even searched for the option with edit, and find. The word TOTAL isn’t on the left screen anyplace, and in edit the virtual server, it isn’t on the right either. I am not kidding.

Hey Howard,

I believe you. Just not sure where it got to. :wink:

Are quotas actually working and enabled on your system? You can check whether they’re enabled in the “Module Config” under the “Other server settings” category.

And if you do a “Recheck Config” it’ll tell you whether quotas are enabled for the filesystem where /home lives.

hey joe, Howard is right, there is nothing that says the word Total in it.
I’ve checked the Module Config and “Quota setup for domain and mail users” is OFF. The Bandwidth monitoring is also off.
The Server Quota is set to Unlimited also.

I’m still having the same problem when trying to upload files via FTP. It doesn’t even reset after a month.

I really dont know what to do.

Hey Adam,

You’ve just answered your own question:

I’ve checked the Module Config and “Quota setup for domain and mail users” is OFF.

You’ve configured Virtualmin not to allow you to edit quotas. If you had previously been using quotas (which, if you are running into quotas and they’re limiting your usage) then those quota settings still exist. Virtualmin just isn’t managing them anymore.

Quotas are a system level feature, with all quota information stored outside of Virtualmin. When Virtualmin reports on quota usage it queries the OS for that information, and when you use Virtualmin to set a quota, it send out a command to the OS to set the quota. The OS doesn’t ask Virtualmin’s opinion about things. :wink:

In short, you need to turn on quota editing, if you want to change quotas with Virtualmin. You could also just use the Disk Quotas module in Webmin to turn them off for your home partition, if you don’t want them at all.

Thank you Joe!
I’ve been trying to figure this out for the longest time on my own but had no Luck :frowning:
I guess I should of read things more carefully.

Thanks again!