Virtualmin Bugs

OS type and version Redhat Enterprise Linux 9.3
Webmin version 2.105
Virtualmin version 7.10.0.gpl
Related packages SUGGESTED

I was doing some work on my Virtualmin server when I noticed some bugs.

  1. 3 of the domains (virtual-servers) were showing as numeric strings like "168119180872510. I somehow found which domains are missing out of the 70 virtual servers I have. The websites were workign fine.

Then I went to “add virtual server” > import virtual server and re-added the missing domains. This seems to have created new numeric IDs for them and things look well.

In /etc/webmin/virtual-server/map.dom they are showing like this:

(Singular line): =168119180872510 1681204807162411
The rest of the lines are like domain.tld=NUMERIC-ID


are empy files.

This is not the case with the other numeric files in the /domains folder - they have content. Is there any way to delete the numeric vhosts (so they don’t show in Virtualmin)?

Because when I go to “Delete Virtual Server”, I am greeted with " Domain 168119180872510 is not valid! ", same for the other one.

  1. For some reason after last IP swap, webmin was going into post install wizard. There was no upgrade done before that. I ran it and it completed.

But when going to “recheck configuration”, I am greeted with an error:

Your system has 15.25 GiB of memory, which is at or above the Virtualmin recommended minimum of 1 GiB

MariaDB 10.5.22 is installed and running

Using network interface eno1 for virtual IPs

Default IPv4 address for virtual servers is <server ip>

Default IP address is set to <server ip>, which matches the detected external address

Disk quotas have been disabled in the module configuration

Shell for FTP users is not included in /etc/shells, which may prevent FTP access

All commands needed to create and restore backups are installed

The selected package management and update systems are installed

Chroot jails are available

The feature Administration user cannot be disabled, as it is used by the following virtual servers : <all my virtual server domains here>

.. your system is not ready for use by Virtualmin

Why is it trying to disable that feature?

I need to say that the IP swap was performed by physically moving the disk to a spare machine, booting and running “nmtui” to update the network connection information. Then I moved it back and did the following steps on its own server:

a) Addresses and NetworkingChange IP Addresses

Ran it twice (once while selecting to change the Real Address and once while selecting to change the External Adress used in DNS records)

which leads us to bug number 3.

  1. When running the above step to change references to the IP, it is not updating DNS records for alias virtual-server (it did it for the main one though). I went to edit the DNS records of the main virtual server and then “manually edit zone file”, saved it and it seems to have updated the aliases. But I suppose, the script for IP references update, should have gone trough them.

Please let me know if any clarification is required.

You haven’t given us your versions. The “Administration user cannot be disabled” error is a bug that has already been fixed, AFAIK, so you seem to be running an older version.

This is all pretty irrelevant without the “REQUIRED” items listed above. You can use the clipboard in the upper left of the dashboard to easily get this information.

OS type and version Debian Linux 11
Webmin version 2.105
Usermin version 2.005
Virtualmin version 7.10.0
Theme version 21.09.5
Package updates All installed packages are up to date

I am sorry, updated the original post with versions.

It is not showing, I retrieved the info by running “virtualmin info host” in an SSH session.

I see it in your post. The little clipboard in the upper right. Middle icon.

Copied blank:


So @Joe, any idea how to fix the bug 1 and 2?

Bug 2 is now miraculously fixed by going to “Features and Plugins” and enabling everything. For some reason it was disabled unbeknownst to me.

But I got a new issue:

  1. It is now not creating Apache virtualhost when I add a new virtual server. :frowning: Therefore SSL virtualhost is also failing.

It’s best to make new topics for each issue.

What error do you get? (Or, if no error, what shows up when you create a new virtual server?)

Saving server details …
… done

Creating administration group rooms …
… done

Creating administration user rooms …
… done

Creating aliases for administration user …
… done

Adding administration user to groups …
… done

Creating home directory …
… done

Creating mailbox for administration user …
… done

Adding new DNS zone …
… done

Adding to email domains list …
… done

Adding DKIM records to DNS domain
… added successfully

Adding new virtual website …
… done

Disabling CGI scripts …
… done

Adding webserver user apache to server’s group …
… done

Performing other Apache configuration …
… done

Creating SSL certificate and private key …
… done

Adding new SSL virtual website …
… could not find non-SSL virtual website to copy directives from!

Setting up log file rotation …
… done

Creating MariaDB login …
… done

Setting up spam filtering …
… done

Setting up AWStats reporting …
… done

Setting up password protection for AWStats …
… done

Creating Webmin user …
… done

Saving server details …
… done

Applying DNS zone for
… done

Re-starting DNS server …
… done

Applying webserver configuration …
… done

Restarting PHP-FPM 8.2 server …
… done

Re-loading Webmin …
… done

Sending email notification to domain owner …
… email sent to

Updating Webmin user …
… done

Creating initial website index page …
… done

Re-loading Webmin …
… done

No error. But there is no virtual host getting created, so it chooses a random existing one to display when going to the domain.

So…what does Features and Plugins look like now?

Going back to this, it seems like maybe something went horribly wrong and the Virtualmin configuration got wiped out, somehow.

Check Server Templates (check the Sever Template you use, Default if you’ve never created others), under “Website for domain”. What’s in “Directives and settings for new websites”?

Features and Plugins

Directives and settings - Blank

So, there it is.

I don’t know how it happened, but it does seem like your Virtualmin configuration (at least a significant chunk of it) is gone. Do you have backups of your /etc directory from before things got weird?

If you have etckeeper installed and working (I don’t think we set it up by default on RHEL, because the etckeeper package on RHEL requires more work to get working), you could also backtrack through the changes in /etc to see when it changed, and also revert the files to a specific commit from before whatever bad thing happened.


Unfortunately I dont have /etckeeper. I copied the directives from an older system and it seems to be working now. I’ll redact the thread that 4th bug has been solved. Thanks for pointing me in the right direction. <3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.