Virtualmin bleeding edge packages for PHP

Hello, big problem for me and maybe a lot of you people: the Joomla! CMS (99% of my websites) will require php 5.3.10 or higher see here and other web stuff require or at least recommend > 5.4. The problem is always the same if we use CentOS, Scientific or Red Hat: the php versions are ancient. And I don’t think that we will get newer versions: CenTOS 6.5 fully updated uses 5.3.3 and we sure don’t have the time to wait for 6.9, just to get like 5.3.5 :slight_smile:

The “why” doesn’t matter here and we all know the answers.

Does the Virtualmin bleeding edge repo still exists (that was so cool of you) and is actively mantained? I guess not 'cause I can’t find anything about it…

If not, will you consider start it again and mantaining some decent php version? This and maybe mySQL being the most common problems for the RHEL-like servers out there. And I preffer sticking with you and not other repos, and having the two php versions side-by-side; that went oh so well :slight_smile:

Thank you!

The same problem exists for upcoming Drupal 8, which requires PHP 5.3.5:

Tiki requires 5.5. Moodle also already requires 5.3.3 - this will be increased in the future. Others will follow…


Are you using 64 bit CentOS?

If so, you can actually run two PHP versions side by side now. Take a peek at the documentation here, and let us know if this will help: