VIRTUALMIN Behind PFSENSE Firewall/router

**Operating system:UBUNTU Server
**OS version:20.04.1

I have installed Virtualmin behind pfsense firewall and I want to control all incoming and outgoing traffic from there. I tried to disable FirewallD and Linux Firewall but when I restart all coming back online again.

How to permanently disable or remove if that possible those firewalls
I don’t understand them and I don’t need to

Thank you

I didn’t know firewalld was even used on Ubuntu. Last time I used it it used something called ufw, which I’m guessing stands for Ubuntu firewall. Have you tried checking the ufw status?

$ sudo ufw status

You may be trying to disable something that doesn’t exist.


well it did come with Virtualmin package. How do I know that firewall then until I installed Virtualmin I never new that FirewallD ever existed :slight_smile:

sudo apt purge firewallD. I do it all the time on virtualmin, since I use different firewall. Then refresh webmin modules or restart machine.

1 Like

I’m guessing they do that for consistency’s sake across distros. In any case, @scotwnw seems to have your solution.


What about Linux firewall how do I remove it as well

Thank you

For the Linux firewall…

Click reset firewall, set to allow all traffic, and check the box NO for activate at boot

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.